MSCRM 4.0: HTTP 401 beim Registrieren eines Workflows

02/12/2008 - 15:13 von Arne Janning | Report spam
Liebe Kollegen,

es tut mir leid, wenn diese Frage hier schon 1000fach beantwortet worden
sein sollte, aber die Google-Groups-Suche spinnt gerade und ich kann nicht
nach alten Beitràgen suchen.

Ich versuche, eine Workflow-Assembly mit plugindeveloper.exe aus dem SDK zu
registrieren und bekomme immer ein Ausnahme: "The request failed with HTTP
status 401: Unauthorized."

Nun ist der Server in der register.xml richtig angegeben, sowie die
Organisation, die Domain, der Username und das Passwort. Hier ist die
register.xml:

<?xml version="1.0" encoding="utf-8" ?>
<Register
LogFile = "Plug-in Registration Log.txt"
Server = "http://moss:5555"
Org = "MicrosoftCRM"
Domain = "litwareinc"
UserName= "Administrator" >
<Solution SourceType="1" Assembly="C:\Microsoft CRM 4.0
SDK\tools\plugindeveloper\bin\Debug\MSCRM.Workflows.ActualizeAddressInContacts.dll">
<WorkflowTypes>
<WorkflowType
TypeName="MSCRM.Workflows.ActualizeAddressInContacts.ActualizeAddressInContactsActivity"
FriendlyName="ActualizeAddressInContacts"/>
</WorkflowTypes>
</Solution>
</Register>

Der Administrator ist System Administrator, verfügt über die nötigen Rechte
und ist im Deployment Manager als Deployment Administrator eingetragen.

Trotzdem kommt immer die Exception. Hat irgendjemand noch eine Idee, woran
das liegen könnte?

Herzliche Grüße

Arne
 

Lesen sie die antworten

#1 Michael Sulz
02/12/2008 - 15:45 | Warnen spam
Hallo Arne,

der Benutzer hat eine Lizenz im CRM? Es reicht nicht, der Administrator zu
sein, der Benutzer benötigt auch eine Lizenz auf dem Server.

mit freundlichen Grüßen

Michael Sulz

Ähnliche fragen