Multiple Choice Auswertung

21/02/2009 - 09:57 von Thfrank | Report spam
Ich würde gerne eine Klausur mit 20 Multiple Choice Fragen auswerten. Meine
Tabelle sieht derzeit so aus, dass in Spalte A der Name steht, in den
folgenden Spalten die Antwortbuchstaben von jedem einzelnen. Die korrekten
Antworten habe ich in einer extra Zeile.

Jetzt möchte ich jede Antwort eines Teilnehmers mit der korrekten Antwort
vergleichen und für eine richtige Antwort einen Punkt geben, am Ende der
Zeile soll dann die Gesamtpunktzahl stehen.

Ich habe versucht, die Abfrage mit vielen WENNs zu machen, aber gibt es
vielleicht eine einfachere Möglichkeit?

Vielen Dank für jeden Tipp
Thomas
 

Lesen sie die antworten

#1 Dietmar Vollmeier
21/02/2009 - 11:26 | Warnen spam
Servus Thomas!

In dieser Gruppe wird ein Realname gerne gesehen :-)

*Thfrank* schrieb am 21.02.2009 um 9:57 Uhr...
Ich würde gerne eine Klausur mit 20 Multiple Choice Fragen auswerten.
Meine Tabelle sieht derzeit so aus, dass in Spalte A der Name steht,
in den folgenden Spalten die Antwortbuchstaben von jedem einzelnen.
Die korrekten Antworten habe ich in einer extra Zeile.

Jetzt möchte ich jede Antwort eines Teilnehmers mit der korrekten
Antwort vergleichen und für eine richtige Antwort einen Punkt geben,
am Ende der Zeile soll dann die Gesamtpunktzahl stehen.

Ich habe versucht, die Abfrage mit vielen WENNs zu machen, aber gibt es
vielleicht eine einfachere Möglichkeit?



Eine kurze Matrix-Formal würde das möglich machen. Schreibe/Kopiere
folgende Formel in die Zelle V1 (oder dort wo das Gesamtergebnis stehen
soll).

=SUMME(--(B1:U1=B$50:U$50))

Dieser Teil *B$50:U$50* der Formel verweist auf den Bereich mit den
richtigen Lösungen. Den mußt du deiner Tabelle noch anpassen. Die
"$"-Zeichen sind wichtig und müssen wieder gesetzt werden.

Schließe die Eingabe mit [Strg]+[Shift]+[Enter] ab.

Kopiere anschließend die Formel soweit wie gewünscht nach unten.

Vielen Dank für jeden Tipp



HTH

und tschüss | To be is to do - Socrates
Didi | To do is to be - Sartre
| Do Be Do Be Do - Sinatra

Ähnliche fragen