Muss ich etwas nachinstllieren?

30/08/2009 - 17:05 von Richard Müller | Report spam
Guten Tag,
ich muss vorausschicken, dass ich Perlskripte nur anwende, aber vom Perl-
Programmieren keine wirkliche Ahnung habe. Ich möchte nun auf einer frisch
aufgesetzten x86_64-Maschine, auf der ein "standardmàßiges" Suse 11.1 làuft
(Perl 5 befindet sich in /usr/lib/perl5), das Skript "vdrsync-gui.pl" laufen
lassen (http://vdrsync.vdr-portal.de/gui/gui-page.html). Beim Start
erscheint folgende Fehlermeldung:
Can't locate Tk.pm in @INC (@INC contains: /usr/lib/perl5/5.10.0/x86_64-
linux-thread-multi /usr/lib/perl5/5.10.0
/usr/lib/perl5/site_perl/5.10.0/x86_64-linux-thread-multi
/usr/lib/perl5/site_perl/5.10.0 /usr/lib/perl5/vendor_perl/5.10.0/x86_64-
linux-thread-multi /usr/lib/perl5/vendor_perl/5.10.0
/usr/lib/perl5/vendor_perl .) at /usr/bin/vdrsync-gui.pl line 28.
BEGIN failed--compilation aborted at /usr/bin/vdrsync-gui.pl line 28.
-
Muss ich dieses Tk.pm noch hàndisch nachinstallieren? Wenn ja, wo finde ich
es? Eine Suche auf CPAN hat keine Datei dieses Namens ergeben.
Gruß, Richard
 

Lesen sie die antworten

#1 Andreas Karrer
30/08/2009 - 21:34 | Warnen spam
* Richard Müller :

Can't locate Tk.pm in @INC (@INC contains: /usr/lib/perl5/5.10.0/x86_64-
linux-thread-multi /usr/lib/perl5/5.10.0
-
Muss ich dieses Tk.pm noch hàndisch nachinstallieren?



Ja. Such mit Yast nach einem Paket namens perl-Tk-xxx.yyy*.x86_64.rpm;
es ist Teil der Suse-Distro. Installier das.

Yast benutzt soweit ich weiss unter der Haube yum, und das installiert
eventuell dafuer notwendige weitere Pakete gleich noch dazu (oder fragt
nach). Perl-Tk via CPAN zu installieren ist deutlich aufwendiger, aber
auch nicht wirklich schwierig.

- Andi

Ähnliche fragen