Nach Installation von Suse 11 kein Windows Boot mehr

20/10/2008 - 10:25 von Christian Steins | Report spam
Hallo,

auf meinem PC habe ich einen Update von Suse 10.1
auf Suse 11 durchgeführt. Nun bootet leider das Windows XP
nicht mehr.

Fehlermeldung: Windows konnte nicht gestartet werden da
folgende Datei fehlt oder fehlerhaft ist:
<windows root>\system32\hal.dll.

Von Linux (auf /dev/sda3) aus kann die NTFS Partition (/dev/sda2)
eingesehen werden und die HAL.DLL ist vorhanden. Swap liegt auf /dev/sda1.

Hier die menu.lst:

# Modified by YaST2. Last modification on So Okt 19 16:39:51 UTC 2008
default 0
timeout 8
##YaST - generic_mbr
gfxmenu (hd0,2)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.0 - 2.6.25.5-1.1
root (hd0,2)
kernel /boot/vmlinuz-2.6.25.5-1.1-pae
root=/dev/disk/by-id/scsi-SATA_IC35L090AVV207-_VNVC02G3E4A4AT-part3
resume=/dev/sda1 splash=silent showopts vga=0x31a
initrd /boot/initrd-2.6.25.5-1.1-pae

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.0 - 2.6.25.5-1.1
root (hd0,2)
kernel /boot/vmlinuz-2.6.25.5-1.1-pae
root=/dev/disk/by-id/scsi-SATA_IC35L090AVV207-_VNVC02G3E4A4AT-part3
showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0
edd=off x11failsafe vga=0x31a
initrd /boot/initrd-2.6.25.5-1.1-pae

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
rootnoverify (hd0,2)
chainloader (hd0,1)+1



Wo könnte der Fehler liegen?

Grüße,
Christian
 

Lesen sie die antworten

#1 Christian Steins
20/10/2008 - 14:38 | Warnen spam
ich schrob:

auf meinem PC habe ich einen Update von Suse 10.1
auf Suse 11 durchgeführt. Nun bootet leider das Windows XP
nicht mehr.

Fehlermeldung: Windows konnte nicht gestartet werden da
folgende Datei fehlt oder fehlerhaft ist:
<windows root>\system32\hal.dll.



Das Problem lag eher auf der Windows Seite.
nach einem fixmbr, fixboot c: und bootcfg /rebuild
geht es wieder. Lustigerweise funktioniert nach dieser Aktion
das Grub-Menü noch, wo der sich wohl eingenistet hat? Anscheinend
nicht im MBR.

Grüße
Christian

Ähnliche fragen