.Net 1.1 Kompatible Programme schreiben

30/11/2007 - 14:32 von D.Follmann | Report spam
Hallo,

ich möchte ein in Visual C# Express ein .NET 1.1 - Kompatibles Programm
schreiben.
Was muss ich dafür machen? reicht es aus wenn ich die Klassen, bei denen in
der Dokumentation steht "Neu in Framework 2.0" einfach nicht verwende, oder
muss ich sonst noch was beachten?

Danke!

MfG
 

Lesen sie die antworten

#1 Thomas Scheidegger
30/11/2007 - 14:50 | Warnen spam
Hallo D.

in Visual C# Express ein .NET 1.1 - Kompatibles Programm schreiben.



der C# 2005/2.0 Compiler kann keine zu 1.1 kompatible Assemblies erstellen.
Nimm VS2003 oder installiere die 2.0-Runtime.

Multi-Targeting erst ab VS2008, aber nicht zurück zur alten 1.1:
http://weblogs.asp.net/scottgu/arch...pport.aspx

Generell sollte man heute neue Programme für 2.0(+) schreiben
(2.0 ist zugleich minimale Vista-Basis, und weiterhin Basis von 3.0/3.5),
nur bei absolut zwingenden Gründen (zB Custom/Embedded Systems) noch für 1.x.






Thomas Scheidegger - 'NETMaster'
http://www.cetus-links.org/oo_dotnet.html - http://dnetmaster.net/

Ähnliche fragen