.NET Framework 2.0 und VS2008

22/04/2009 - 11:06 von Reiner Hoehnke | Report spam
Hallo,

ich habe eine Software mit VS2005 und .NET Framework 2.0 entwickelt. Ich
möchte jetzt, dass die Software auch mit .NET Framework 3.5 funktioniert,
ohne .NET Framework 2.0 installieren zu müssen.

Heißt Das, dass ich jetzt auch auf VS2008 upgraden muss, oder kann ich mit
.NET Framework 3.5 auch unter VS2005 entwickeln.

Danke für die Hilfe im Voraus

Reiner
 

Lesen sie die antworten

#1 Armin Zingler
22/04/2009 - 13:02 | Warnen spam
Reiner Hoehnke wrote:
Hallo,

ich habe eine Software mit VS2005 und .NET Framework 2.0 entwickelt.
Ich möchte jetzt, dass die Software auch mit .NET Framework 3.5
funktioniert, ohne .NET Framework 2.0 installieren zu müssen.

Heißt Das, dass ich jetzt auch auf VS2008 upgraden muss, oder kann
ich mit .NET Framework 3.5 auch unter VS2005 entwickeln.



VS2005 ist auf das Framework 2.0 beschrànkt. Das macht aber nichts, weil die
Framework 3.5-Installation die Version 2.0 mit einschließt. Beide verwenden
dieselbe Runtime (2.0), nur sind beim Framework 3.0/3.5 zusàtzliche
Bibliotheken dabei. Wenn du diese Bibliotheken nicht nutzen willst, kannst
du bei VS 2005 bleiben. Auf dem Zielrechner sollte dann mindestens 2.0 bzw
"heutzutage" gleich 3.5 installiert sein.


Armin

Ähnliche fragen