Netzwerkboot friert ein

01/09/2007 - 22:20 von S.K.V. | Report spam
Hallo Leute,

ich versuche hier einen Rechner ohne Platten mittels pxelinux zu booten.
Der Rechner selber hat eine Onboard 3x520b Karte die aber leider nicht
von sich aus booten kann, daher habe ich mir eine etherboot-CD
hergestellt.

Nachdem ich die kleine zeile "next-server (ip)" eingefügt habe erhalte
ich nun wunderbar von dem DHCP-Server ip, gateway und tftp-Server-IP.
Soweit klappt nun alles Problem ist das Booten selber.

Ich erhalte folgende meldungen:

ME: 192.168.8.3, DHCP 192.168.8.2, TFTP: 192.168.8.2, Gateway 192.168.8.1
Loading 192.168.8.2:pxelinux.0 ..


und das wars an dieser stelle friert das System ein.

MAch ich den Server mit -v -v etwas geschwàtziger erhalte ich die
Meldung, das eine IP-Vergeben wurde und dann:

in.tftpd[2713]: connect from 192.168.8.3 (192.168.8.3)
in.tftpd[2714]: RRQ from 192.168.8.3 filename pxelinux.0


sprich die Datei findet er auch aber mehr kommt da nicht.

Jemand ne Idee was ich da falsch mache. Kann ich den Debug noch höher
drehen, damit er mir noch mehr erzàhlt, weil das das der höchste Level
ist kann ich mir nicht wirklich vorstellen.

Der tftp wird mittels -s /srv/tftp aufgerufen.

in dem Hauptverzeichnis befindet sich die pxelinux.0, pxelinux.cfg und
minimyth (letzten beiden sind Verzeichnisse)

in default die in pxelinux.cfg ist steht:

DEFAULT minimyth

LABEL minimyth
KERNEL minimyth/kernel
APPEND ro root=/dev/nfs nfsroot2.168.8.2:/srv/nfs/minimyth
ip=dhcp


So ich hoffe ich habe keine Info vergessen!!!

Danke schon mal für alle Hinweise

Steve
 

Lesen sie die antworten

#1 Fritz Schadt
04/09/2007 - 23:23 | Warnen spam
S.K.V. wrote:
Hallo Leute,

ich versuche hier einen Rechner ohne Platten mittels pxelinux zu booten.
Der Rechner selber hat eine Onboard 3x520b Karte die aber leider nicht
von sich aus booten kann, daher habe ich mir eine etherboot-CD
hergestellt.

Nachdem ich die kleine zeile "next-server (ip)" eingef?gt habe erhalte
ich nun wunderbar von dem DHCP-Server ip, gateway und tftp-Server-IP.
Soweit klappt nun alles Problem ist das Booten selber.

Ich erhalte folgende meldungen:

ME: 192.168.8.3, DHCP 192.168.8.2, TFTP: 192.168.8.2, Gateway 192.168.8.1
Loading 192.168.8.2:pxelinux.0 ..


und das wars an dieser stelle friert das System ein.

MAch ich den Server mit -v -v etwas geschw?tziger erhalte ich die
Meldung, das eine IP-Vergeben wurde und dann:

in.tftpd[2713]: connect from 192.168.8.3 (192.168.8.3)
in.tftpd[2714]: RRQ from 192.168.8.3 filename pxelinux.0



[...]

routet das Gateway auch ins eigene Netz? Oder - nimm den Eintrag mit
dem Router mal Testweise aus der dhcpd.conf. Das pxelinux.0 wird vom
Kartenbios geladen, der Rest dann von pxelinux.0. Und die Verhalten
sich unterschiedlich. Du hast doch das neueste pxelinux?

HTH
fs
Zymurgy's Law of Volunteer Labor:
People are always available for work in the past tense.

Ähnliche fragen