Netzwerkkarte läuft nur in einem bestimmte PCI-Slot

17/08/2015 - 14:03 von Wolfgang Klein | Report spam
Hallo!

Folgende HW-Kombi bereitet Probleme:

- Hauptplatine: American Megatrends Inc
- PCI-Netzwerkkarte TP-Link: RTL8169 PCI Gigabit Ethernet Controller

Die Angaben stammen jeweils von lshw.

Die Netzwerkkarte funktioniert dabei nur in einem der beiden PCI-Slots,
in dem anderen spielt sie toter Mann. Beide Slots sind aber in Ordnung,
andere Karten laufen in beiden Slots.

Sollte es wirklich so sein, daß es im Jahre 2015 noch IRQ-Konflikte gibt??

Wenn ja: kann man das unter Linux per Software beheben?



Wolfgang
 

Lesen sie die antworten

#1 Marcel Mueller
18/08/2015 - 02:04 | Warnen spam
On 17.08.15 14.03, Wolfgang Klein wrote:
Die Netzwerkkarte funktioniert dabei nur in einem der beiden PCI-Slots,
in dem anderen spielt sie toter Mann. Beide Slots sind aber in Ordnung,
andere Karten laufen in beiden Slots.



Das ist aber keine hinreichende Bedingung. Nicht jede Karte nutzt jedes
Feature.

Sollte es wirklich so sein, daß es im Jahre 2015 noch IRQ-Konflikte gibt??



Möglich ist alles, aber in Zeiten von APIC eigentlich unwahrscheinlich.
Was sagt denn lspci -v ?

Ein Blick in dmesg würde sich vermutlich auch mal lohnen. Vor allem im
Delta funktionierend vs. nicht funktionierend.

Wenn ja: kann man das unter Linux per Software beheben?



Klar, Treiber fixen. ;-)
Wenn es denn überhaupt daran liegt, was ich nicht vermute.

Realistisch betrachtet, würde ich einfach den funktionierenden Slot
verwenden. Oder möchtest Du Stiftung Warentest spielen und
Kompatibilitàtstests machen?

Btw. Was verstehst Du unter Toter Mann? Wird das PCI-Device nicht
gefunden? Làdt nur der Treiber nicht? Kommt nur keine Verbindung zustande?
So Umsteckorgien bringen nàmlich auch gerne mal die /dev/ethX
Reihenfolge durcheinander. Wenn man dann irgendeine Config hart auf eth0
kodiert hat, war es das.


Marcel

Ähnliche fragen