Netzwerklaufwerke

14/10/2008 - 14:16 von Alf Benn | Report spam
Hallo NG,

wir haben folgendes Prob mit unserer Software. Ein Home Premium Client hat
ein verbundenes Netzwerklaufwerk (auf einem Domainserver) f:\ (mit anderem
Benutzernamen verbunden als so etwas wie domàne\benutzer Passwort). Zugriff
via Arbeitsplatz Explorer funzt, wenn dann unserer eigenes Programm (exe)
darauf zugreifen will, kommt nach einiger Zeit die Aufforderung Benutzername
und Kennwort einzugeben, wenn man dann wieder die gleichen Benutzerdaten,
also domàne\benutzer samt Passwort eingibt klappert der Zugriff, sonst
nicht.
Ich glaube, das unsere Proggies den Laufwerksbuchstaben in einen UNC-Pfad
"umbasteln" und der Zugriff dann via UNC-Pfad (\\server\daten) làuft. Wàre
das eine mögliche Erklàrung für dieses Problem und wie kann man so etwas
"umschiffen".

Bin dankkbar für eure Tipps und Hilfen


Danke und Gruss
Alf
 

Lesen sie die antworten

#1 Winfried Sonntag [MVP]
14/10/2008 - 14:42 | Warnen spam
Alf Benn schrieb:

Ich glaube, das unsere Proggies den Laufwerksbuchstaben in einen UNC-Pfad
"umbasteln" und der Zugriff dann via UNC-Pfad (\\server\daten) làuft.



Das solltet ihr besser wissen, wenn ihr die Autoren der Programm seid.
;)

Wàre das eine mögliche Erklàrung für dieses Problem und wie kann man
so etwas "umschiffen".



Ohne genaueres zu wissen könntest Du diese Zeile in eine Batch packen
und auf dem Client ausführen:
net use \\DeinServer "passwort" /user:deinedom\Benutzer
Wenn Du das Passwort weglàsst, mußt Du es eintippen.

BTW: Ein *-Home-Client hat in keinem Firmen-LAN etwas zu suchen.

Servus
Winfried
Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
GPO's: http://www.gruppenrichtlinien.de
Gruppenrichtlinien Mailingliste "gpupdate":
http://frickelsoft.net/cms/index.ph...ilingliste

Ähnliche fragen