Forums Neueste Beiträge
 

Netzwerkproblem mit mehreren Netzkarten

05/07/2010 - 12:02 von Werner Flamme | Report spam
Hallo miteinander,

wir ràtseln hier über ein merkwürdiges Netzwerkproblem. Es geht darum, 3
Server mit SLES9, die jetzt Adressen in 2 Subnetzen haben, in VMs (mit
SLES 11) umzuziehen. Die VMs (auf VMWare vSphere 4 ESX) haben die
gleichen Subnetze wie die physikalischen Server.

Bei den physikalischen Servern ist es so, dass sie je eine Adresse in
141.65.128.0/24 und mindestens eine in 141.65.171.0/24 haben. Beide
Adressen sind anpingbar und man kann sich per ssh mit beiden Adressen
verbinden. Default-Gateway ist bei allen 141.65.128.1.

Die VMs sind im Prinzip genau so konfiguriert, eine Adresse in
141.65.128.0/24 und mindestens eine in 141.65.171.0/24. Jetzt kommt es
zum Ràtsel: wenn das Default-Gateway auf 141.65.171.1 steht, kann man
sich per ssh an die 171er Adresse anmelden; pingbar ist sie auch. Die
128er Adresse antwortet nicht auf ping nd ssh-Zugriffe erhalten
timeouts. Es sei denn, man versucht es von einer anderen Maschine aus
dem Subnetz 141.65.128.0/24, dann klappt sowohl ping, arping als auch
ssh. Die genannte "andere Maschine" ihrerseits ist problemlos aus
anderen Subnetzen anping- und ssh-bar.

Was kann die Ursache dafür sein, dass die VMs sich außerhalb ihres
Subnetzes nicht zeigen? Wàren sie gar nicht erreichbar, würde ich es
einen Konfigurationsfehler in der VM oder auf dem ESX (4.0) nennen. Aber
so? Beide Subnetze werden auf einer gemeinsamen Netzwerkkarte angebunden
(trunk auf der Cisco-Switch), und der 171er-Teil funktioniert ja auch...

Sachdienliche Hinweise werden gern entgegengenommen.

Gruß
Werner
 

Lesen sie die antworten

#1 Heiko Schlenker
05/07/2010 - 13:56 | Warnen spam
* Werner Flamme schrieb:
Sachdienliche Hinweise werden gern entgegengenommen.



Die Newsgroup de.comp.virtualisierung dürfte thematisch
besser geeignet sein.

Gruß, Heiko
Neu im Usenet? -> http://www.kirchwitz.de/~amk/dni/
Linux-Anfànger(in)? -> http://www.dcoul.de/infos/
Fragen zu KDE/GNOME? -> de.comp.os.unix.apps.{kde,gnome}
Passende Newsgroup gesucht? -> http://groups.google.com/search?as_umsgid=

Ähnliche fragen