newbie: Installation einer älteren FreeBSD-Version

01/03/2010 - 13:20 von Thomas Günther | Report spam
Hallo,

ich hatte mit mit FreeBSD oder generell BSD bisher noch nicht zu tun.
Meine Aufgabe ist es nun, die Administration einiger àlterer Server zu
übernehmen. Auf den Servern làuft FreeBSD 6.2. Zu Testzwecken möchte
ich jetzt einen weiteren Server aufsetzen.
Eine 6.2er Minimalversion habe ich installiert. Jetzt fangen die
Schwierigkeiten an. Für das Nachziehen weiterer Pakete habe ich
PACKAGEROOT ftp://ftp-archive.freebsd.org
PACKAGESITE /pub/FreeBSD-Archive/old-releases/i386/6.2-RELEASE/

gesetzt. Ein 'pkg_add -r bash' bringt mir aber den Fehler:
pkg_add: can't stat package file 'bash'

Wo liegt das Problem, bzw. was mach ich falsch? Kann mir jemand weiter
helfen?


Gruss und Danke
Thomas
 

Lesen sie die antworten

#1 Christian Baer
01/03/2010 - 15:39 | Warnen spam
Thomas Günther schrieb:

gesetzt. Ein 'pkg_add -r bash' bringt mir aber den Fehler:
pkg_add: can't stat package file 'bash'

Wo liegt das Problem, bzw. was mach ich falsch? Kann mir jemand weiter
helfen?



Für eine genaue Analyse mußt Du bei xBSD schon die Plattform angeben,
die macht nàmlich gerade in diesem Fall schon was aus. Ich gehe mal
davon aus, daß Du i386 verwendest.

Ist jetzt reine Spekulation [ich bin jetzt zu faul nachzusehen :-) ],
aber erfahrungsgemàß verschwinden die vorgebauten Pakete recht schnell
wieder von den Servern, da sie Unmengen an Platz verbraten. Du bekommst
die praktisch nur noch für das "legacy-Release" (in diesem Fall 7.x).

Wenn Du Software nachinstallieren möchtest, machst Du das besser über
die Ports. Da gibt es aber nur eine current-Version (tag=.), von daher
gibt es auch keine Garantie, daß die Dinger wirklich richtig gebaut
werden. Meiner Erfahrung nach klappen die meisten Sachen aber problemlos.

Darf ich mal fragen, warum Du eine àltere Version installieren möchtest?

Gruß
Christian

Ich kam.
Ich ging.
Und ich war da gewesen.

Ähnliche fragen