NFS Verbindung stirbt nach Inaktivität

29/12/2010 - 22:41 von Marcel Müller | Report spam
Hallo,

ich habe seit kurzem das Problem, dass ein NFS-Mount nach einer Weile
Inaktivitàt immer stirbt. Es ist NFS3 und Client ist Ubuntu 10.04,
Server ist eComStation.

Von den Symptomen sieht es so aus, dass alle Programme, die etwas damit
zu tun haben, hàngen bleiben (z.B. ls), bis ich mit umount -f Tatsachen
schaffe.

Gefühlt raucht die Verbindung nach grob einer halben Stunde Pause ab.
Solange man arbeitet, hàlt sie.

Das ganze lief geschàtze 3 Monate fehlerfrei, bis vor ein paar Tagen
plötzlich der Ärger los ging. Client und Server sind beide VMs, die 24/7
laufen. Die Konfiguration ist unveràndert, allerdings hat Ubuntu sich
vor kurzem mal wieder einen neuen Kernel gezogen, falls das relevant ist.

mm2:D /home/mm/MM2/D nfs rw,intr 0 0

Kann man da irgendetwas bei den Mount-Options drehen, so dass er ein
Keep-Alive macht oder so? Sofern es überhaupt timeouts sind.


Marcel
 

Lesen sie die antworten

#1 Michael Baeuerle
30/12/2010 - 09:52 | Warnen spam
Marcel Müller wrote:

mm2:D /home/mm/MM2/D nfs rw,intr 0 0



Du koenntest mal noch versuchen, NFS ueber TCP laufen zu lassen wenn das
unterstuetzt wird. Das verhaelt sich dann teilweise anders.

Kann man da irgendetwas bei den Mount-Options drehen, so dass er ein
Keep-Alive macht oder so? Sofern es überhaupt timeouts sind.



Ich hatte das gleiche Problem mit einem (alten) Linux als Client und
einem NetBSD Server. Als Workaround hatte ich auf dem Server eine
Dummy-Datei liegen und auf dem Client ein Script im Hintergrund laufen
das da alle paar Sekunden drauf zugreift.


Micha
Irgendwann wird die Welt untergehen und das juengste Gericht kommen,
steht in der Bibel. Aber sicher nicht aufgrund des Fehlens von
Railtaxis ;-)
Joerg in defa

Ähnliche fragen