NIC ohne IP

03/06/2011 - 18:53 von Stefan Ceran | Report spam
Hallo,

seit ich von Debian Lenny ein Update auf Squeeze durchgeführt habe, habe
ich Probleme mit dem Hochfahren der Netzwerkkarte.

In /etc/network/interfaces ist die Karte so konfiguriert:

allow-hotplug eth0
auto eth0
iface eth0 inet static
address 192.168.1.1
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255

Nach dem Hochfahren des Rechners hat die Karte keine IP-Adresse:
#ifconfig

eth0 Link encap:Ethernet HWaddr XXX
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:23 Base address:0xa000

Wenn ich manuell ein /etc/init.d/networking restart durchführe, kommt zwar
die Meldung:

Running /etc/init.d/networking restart is deprecated because it may not
enable again some interfaces ... (warning).
Reconfiguring network interfaces...done.

danach hat die Karte aber die IP 192.168.1.1

Es handelt sich folgende Karte (#lspic):
02:0b.0 Ethernet controller: 3Com Corporation 3c905B 100BaseTX [Cyclone]
(rev 30)

Und folgender Kernel làuft: Linux server 2.6.38.6

Irgendwelche Ideen, was da beim Booten schief geht?

Danke.

Grüße,
Stefan
 

Lesen sie die antworten

#1 Oliver Sch
03/06/2011 - 19:12 | Warnen spam
Stefan Ceran wrote:

seit ich von Debian Lenny ein Update auf Squeeze durchgeführt habe,
habe ich Probleme mit dem Hochfahren der Netzwerkkarte.


[...]
Irgendwelche Ideen, was da beim Booten schief geht?



Im Zweifel ins Log schauen: /var/log/syslog

Z.B. könnte der Treiber zu spàt geladen werden.

mfg
Oli

Man darf ruhig intelligent sein, man muss sich nur zu helfen wissen

Ähnliche fragen