nichtnumerische Werte mit Funktion "Teilergebnis 2" zaehlbar?

08/05/2009 - 16:19 von Gerhard Wolf | Report spam
Hallo zusammen,

mit Eurer Hilfe hatte ich schon vor einiger Zeit diese Formel erstellt, um
in einem Datensatz die Funktion „Zàhlen wenn“ zu ersetzen, so dass das
Ergebnis auch auf Filterungen reagiert.

=SUMMENPRODUKT(TEILERGEBNIS(2;INDIREKT("Daten!B"&ZEILE(Daten!3:986)))*(Daten!B3:B986=1))
für Werte 1 bis 6.



Gibt es eine Möglichkeit, dass mit dieser Formel auch „x“ oder ein anderes
nichtnumerisches Zeichen gezàhlt wird?

Die Eingabe ...)))*(Daten!B3:B986=“x“)) führte bei mir zu falschen
Werten. Mit der Funktion „Zàhlen wenn“ funktioniert es.

Danke schon jetzt



Gerhard
 

Lesen sie die antworten

#1 Thomas Ramel
08/05/2009 - 17:05 | Warnen spam
Grüezi Gerhard

Gerhard Wolf schrieb am 08.05.2009

mit Eurer Hilfe hatte ich schon vor einiger Zeit diese Formel erstellt, um
in einem Datensatz die Funktion „Zàhlen wenn“ zu ersetzen, so dass das
Ergebnis auch auf Filterungen reagiert.

=SUMMENPRODUKT(TEILERGEBNIS(2;INDIREKT("Daten!B"&ZEILE(Daten!3:986)))*(Daten!B3:B986=1))
für Werte 1 bis 6.

Gibt es eine Möglichkeit, dass mit dieser Formel auch „x“ oder ein anderes
nichtnumerisches Zeichen gezàhlt wird?

Die Eingabe ...)))*(Daten!B3:B986=“x“)) führte bei mir zu falschen
Werten. Mit der Funktion „Zàhlen wenn“ funktioniert es.



Das müsste aber eigentlich schon passen, wenn Du 'x' auch als String in der
Formel auweist:

=SUMMENPRODUKT(TEILERGEBNIS(2;INDIREKT("Daten!B"&ZEILE(Daten!3:986)))*(Daten!B3:B986="x"))



Mit freundlichen Grüssen
Thomas Ramel

- MVP für Microsoft-Excel -
[Vista Ultimate SP-1 / xl2007 SP-1]

Ähnliche fragen