Nltest und multihomed W2k3DC

04/02/2010 - 11:48 von André Heublein | Report spam
Hallo Leute,

2 DC´s (W2k3Sp2) haben jeweils 2 Netzwerkkarten für 2 unterschiedliche
Subnetze.
Auf dem primàren Interface ist die DNS Registrierung eingeschaltet, auf dem
2.ten nicht.

DNS-technisch sieht das so aus:

Forward lookup zone
domàne.local
dc01 host(a) 192.168.1.1

Die Server sind mit der 2.ten NIC bzw. 2.ten IP nicht im DNS registriert.


Nun habe ich das Problem, dass mein Storage die DC´s über die 2.te nicht
primàre IP anspricht, jedoch hier aufgrund von Nicht-Bindung vom MS
Client-Netzwerk-Client sowie Datei/Druckerfreigabe keinen Erfolg hat (auch
haben soll; er soll auf dem primàren connecten).

Das eigentliche Problem ist, dass der Storage die IP vom 2.ten, nicht
primàren Interface zurückbekommt, lt Aussage von EMC (und auch techn.
Verstàndnis) per DNS SRV/A Records).

Die erste Anlaufstelle, DNS, habe ich von vorn bis hinten überprüft, hier
steht in keinem der SRV Records bzw. anschließend im abzufragenden A-Record
die 2.te IP drin.
Die 2.te Anlaufstelle, WINS, kein Eintrag von 2.ten Interface des DC´s.

Ich habe alle MS KB Artikel zum Multihomed DC durchgearbeitet, alles OK
Ich habe folgenden Artikel durchgearbeitet:
http://support.microsoft.com/kb/247811

und bin dabei auf nltest /dsgetdc:domàne gestossen. Auf den DC´s holt mit
dieser Befehl (auch mit /force) zwar den korrekten Namen, jedoch immer die
falsche IP des 2.ten Interfaces.

Auf 3 getesteten XP Sp3 Clients bekomme ich immer die korrekte IP.

Lt. EMC holt sich der Storage seine Informationen auch nur aus dem DNS;
weshalb hier unterschiedliche Informationen rauskommen, weiss ich noch
nicht.
Die Replikation zwsichen den DNS (AD integriert) bzw. AD Server ist auch
sauber, überprüft per Ereignisanzeige/replmon

Im Netz habe ich das gleiche Problem schon gefunden, jedoch keine
Erklàrung/Lösung hierzu.
Deshalb hoffe ich nun hier, weitrere hilfreiche Informationen zu erhalten.

André
 

Lesen sie die antworten

#1 RCan
04/02/2010 - 19:56 | Warnen spam
Denke das Problem hier ist, das im DNS noch die IP der zweiten NIC steht,
siehe dir mal folgenden Artikel an :
http://support.microsoft.com/kb/272294

Zudem glaube ich das du hier deinen Fehler im DNS suchen musst, da "nltest
/dsgetdc:" die ergebnisse vom DNS einholt.

Meine persönliche Meinung hierzu ist : Ich kann nur davon abraten einen DC
dualhomed zu betreiben, ist das Szenario wirklich nicht anders realisierbar
(Sites and Services, IP routing) ?! Sofern es technisch korrekt
implementiert ist, funktioniert es aber .

Gruß
Ramazan

"André Heublein" wrote in message
news:
Hallo Leute,

2 DCŽs (W2k3Sp2) haben jeweils 2 Netzwerkkarten für 2 unterschiedliche
Subnetze.
Auf dem primàren Interface ist die DNS Registrierung eingeschaltet, auf
dem 2.ten nicht.

DNS-technisch sieht das so aus:

Forward lookup zone
domàne.local
dc01 host(a) 192.168.1.1

Die Server sind mit der 2.ten NIC bzw. 2.ten IP nicht im DNS registriert.


Nun habe ich das Problem, dass mein Storage die DCŽs über die 2.te nicht
primàre IP anspricht, jedoch hier aufgrund von Nicht-Bindung vom MS
Client-Netzwerk-Client sowie Datei/Druckerfreigabe keinen Erfolg hat (auch
haben soll; er soll auf dem primàren connecten).

Das eigentliche Problem ist, dass der Storage die IP vom 2.ten, nicht
primàren Interface zurückbekommt, lt Aussage von EMC (und auch techn.
Verstàndnis) per DNS SRV/A Records).

Die erste Anlaufstelle, DNS, habe ich von vorn bis hinten überprüft, hier
steht in keinem der SRV Records bzw. anschließend im abzufragenden
A-Record die 2.te IP drin.
Die 2.te Anlaufstelle, WINS, kein Eintrag von 2.ten Interface des DCŽs.

Ich habe alle MS KB Artikel zum Multihomed DC durchgearbeitet, alles OK
Ich habe folgenden Artikel durchgearbeitet:
http://support.microsoft.com/kb/247811

und bin dabei auf nltest /dsgetdc:domàne gestossen. Auf den DCŽs holt
mit dieser Befehl (auch mit /force) zwar den korrekten Namen, jedoch immer
die falsche IP des 2.ten Interfaces.

Auf 3 getesteten XP Sp3 Clients bekomme ich immer die korrekte IP.

Lt. EMC holt sich der Storage seine Informationen auch nur aus dem DNS;
weshalb hier unterschiedliche Informationen rauskommen, weiss ich noch
nicht.
Die Replikation zwsichen den DNS (AD integriert) bzw. AD Server ist auch
sauber, überprüft per Ereignisanzeige/replmon

Im Netz habe ich das gleiche Problem schon gefunden, jedoch keine
Erklàrung/Lösung hierzu.
Deshalb hoffe ich nun hier, weitrere hilfreiche Informationen zu erhalten.

André


Ähnliche fragen