NonThreadSafe - Preconfiguration schlaegt fehl

08/11/2009 - 17:51 von Thomas Steinbach | Report spam
Hallo,

ich bekomme folgende Fehlermeldung, wenn ich Apache mit den
Non-Thread-Safe Modul (php5apache2_2.dll, ver 5.2.11) starte/teste

[...] [crit] Apache is running a threaded MPM, but your PHP Module
is not compiled to be threadsafe. You need to recompile PHP.
Pre-configuration failed

Wie kann man PHP 5.2.11 (non thread safe) als Modul mit dem
Apache 5.2.11 nutzen? Es muss ja irgendwie gehen, denn sonst
waeren diese Module ja nicht bei der NTS Version dabei. Oder?
Ich meine nicht die ueblichen Konfigurationseintragungen.
LoadModule, ScripAlias etc., sondern eben nur das Problem
der NTS _Module_ (nicht CGI) mit Apache.

Thomas
 

Lesen sie die antworten

#1 Carsten Wiedmann
09/11/2009 - 09:00 | Warnen spam
Thomas Steinbach schrieb:
Wie kann man PHP 5.2.11 (non thread safe) als Modul mit dem
Apache 5.2.11 nutzen?



Gar nicht. Du must dann PHP als CGI oder FastCGI (mod_fcgid) im Apache
einrichten.

Gruß
Carsten

Ähnliche fragen