NVidia-Treiber

13/02/2009 - 20:23 von Hendric Stattmann | Report spam
Hallo an alle,

Ich habe ein System (Intel Core2 Duo, mit Nvidia 8400GS GraKa) mit SuSE 11.0
x_64 aufgesetzt. Standardmàßig wurde der NVIDIA Treiber 173.x.y installiert,
der auch recht ordentlich funktionierte.
Um die Graphikkarte optimal zu nutzen, möchte ich allerdings den 180.22
verwenden. Ich habe das NVidia Repository eingebunden und folgende Pakete
anstelle der 173er installiert:

nvidia-gfxG02-kmp-default-180.22_2.6.25.18_0.2-4.1
x11-video-nvidiaG02-180.22-4.1

Leider kann ich mit diesen Treibern den X-Server nicht starten, es erscheint
folgende Fehlermeldung im /var/log/messages :

Feb 13 20:06:39 blechdose kernel: nvidia: module license 'NVIDIA' taints
kernel.
Feb 13 20:06:39 blechdose kernel: NVRM: The NVIDIA probe routine was not
called for 1 device(s).
Feb 13 20:06:39 blechdose kernel: NVRM: This can occur when a driver such as
rivafb, nvidiafb or
Feb 13 20:06:39 blechdose kernel: NVRM: rivatv was loaded and obtained
ownership of the NVIDIA
Feb 13 20:06:39 blechdose kernel: NVRM: device(s).
Feb 13 20:06:39 blechdose kernel: NVRM: Try unloading the rivafb, nvidiafb
or rivatv kernel module
Feb 13 20:06:39 blechdose kernel: NVRM: (and/or reconfigure your kernel
without rivafb/
nvidiafb
Feb 13 20:06:39 blechdose kernel: NVRM: support), then try loading the
NVIDIA kernel module again.
Feb 13 20:06:39 blechdose kernel: NVRM: No NVIDIA graphics adapter probed!

Keines der angemeckerten Module ist geladen (lt. lsmod), auch ein Neustart
bringt keine Besserung.

Frage: Hat jemand àhnliche Erfahrungen, oder kann helfen?

Freundliche Grüße,
Hendric
 

Lesen sie die antworten

#1 Matthias Gerds
13/02/2009 - 20:50 | Warnen spam
Hendric Stattmann []
schrieb am Freitag, 13. Februar 2009 20:23:

Hallo an alle,

Ich habe ein System (Intel Core2 Duo, mit Nvidia 8400GS GraKa) mit
SuSE 11.0 x_64 aufgesetzt. Standardmàßig wurde der NVIDIA Treiber
173.x.y installiert, der auch recht ordentlich funktionierte.
Um die Graphikkarte optimal zu nutzen, möchte ich allerdings den
180.22 verwenden. Ich habe das NVidia Repository eingebunden und
folgende Pakete anstelle der 173er installiert:

nvidia-gfxG02-kmp-default-180.22_2.6.25.18_0.2-4.1
x11-video-nvidiaG02-180.22-4.1

Leider kann ich mit diesen Treibern den X-Server nicht starten, es
erscheint folgende Fehlermeldung im /var/log/messages :

Feb 13 20:06:39 blechdose kernel: nvidia: module license 'NVIDIA'
taints kernel.
Feb 13 20:06:39 blechdose kernel: NVRM: The NVIDIA probe routine was
not called for 1 device(s).
Feb 13 20:06:39 blechdose kernel: NVRM: This can occur when a driver
such as rivafb, nvidiafb or
Feb 13 20:06:39 blechdose kernel: NVRM: rivatv was loaded and obtained
ownership of the NVIDIA
Feb 13 20:06:39 blechdose kernel: NVRM: device(s).
Feb 13 20:06:39 blechdose kernel: NVRM: Try unloading the rivafb,
nvidiafb or rivatv kernel module
Feb 13 20:06:39 blechdose kernel: NVRM: (and/or reconfigure your
kernel without rivafb/
nvidiafb
Feb 13 20:06:39 blechdose kernel: NVRM: support), then try loading the
NVIDIA kernel module again.
Feb 13 20:06:39 blechdose kernel: NVRM: No NVIDIA graphics adapter
probed!

Keines der angemeckerten Module ist geladen (lt. lsmod), auch ein
Neustart bringt keine Besserung.

Frage: Hat jemand àhnliche Erfahrungen, oder kann helfen?

Freundliche Grüße,
Hendric



Hmm, weiß nicht, k. A. ob das über das Repository überhaupt so
funktioniert. Würde das lieber im Textmodus mit der heruntergeladenen
Originaldatei

NVIDIA-Linux-x86-180.22-pkg1.run

von NVidia im Systemverwaltermodus (root) machen. Das musst Du
allerdings dann jedes Mal machen, wenn ein neuer Kernel installiert
wurde.

MG


Asus K8N-E AMD64 3000+ 2 GB
Kernel 2.6.25 openSUSE 11.0
KDE 3.5.9 Blackbox 0.70.1

Ähnliche fragen