nvidia Treiber unter fedora11 nach update

01/08/2009 - 10:17 von Richard Ruhland | Report spam
Hallo,

habe sein neuesten ein Problem mit NVIDIA (Prob. Treiber von nvidia.com) unter fedora11.
Seit ich die Updates von Fedora11 eingespielt habe, bekommen ich den nvidia Treiber nicht mehr
zum laufen, Fehlermeldungen in Xorg.0.log sind die Folge. Der nouveau Treiber hingegen
funktioniert hingegen ohne Probleme. Ich möchte 3D nutzen.


Habt ihr eine Idee was es seinen könnte? Vorher hat es ja Funktioniert und nach den Update nicht mehr.

Danke für die Hilfe!!

Gruss Richard

Anlage:
* Xorg.0.log
* xorg.conf
* Kernel Version
* Grafikkartentyp


Linux linux.domain 2.6.29.6-213.fc11.i686.PAE #1 SMP Tue Jul 7 20:59:29 EDT 2009 i686 athlon i386 GNU/Linux

NIVIDIA Karte 8800GT

Folgende Fehlermeldung erscheinen in Xorg.0.log:

#####################################################################
X.Org X Server 1.6.1.901 (1.6.2 RC 1)
Release Date: 2009-5-8
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.18-128.1.6.el5 i686
Current Operating System: Linux linux.domain 2.6.29.6-213.fc11.i686.PAE #1 SMP Tue Jul 7 20:59:29 EDT 2009
i686
Kernel command line: ro root=/dev/mapper/vg_linux-lv_root rhgb quiet
Build Date: 18 May 2009 02:47:59PM
Build ID: xorg-x11-server 1.6.1.901-1.fc11
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Aug 1 09:56:27 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Monitor0"
(**) | |-->Device "Videocard0"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(==) Automatically adding devices
(==) Automatically enabling devices
(**) FontPath set to:
/usr/share/fonts/default/Type1,
catalogue:/etc/X11/fontpath.d,
built-ins
(==) ModulePath set to "/usr/lib/xorg/modules"
(**) Extension "Composite" is enabled
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Mouse0
(WW) Disabling Keyboard0
(II) Loader magic: 0x640
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.4
X.Org Video Driver: 5.0
X.Org XInput driver : 4.0
X.Org Server Extension : 2.0
(II) Loader running on linux
(--) using VT number 7

(--) PCI:*(0@4:0:0) nVidia Corporation GeForce 8800 GT rev 162, Mem @ 0xfd000000/16777216,
0xd0000000/268435456, 0xfa000000/33554432, I/O @ 0x0000ec00/128, BIOS @ 0x????????/131072
(II) No APM support in BIOS or kernel
(II) System resource ranges:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[5] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[6] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[7] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[8] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[9] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[10] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[11] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[12] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[13] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[14] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[15] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[16] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[17] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[18] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[19] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[20] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[21] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[22] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[23] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "record" will be loaded by default.
(II) "dri" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri2" will be loaded by default.
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
compiled for 1.6.1.901, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "type1"
(WW) Warning, couldn't open module type1
(II) UnloadModule: "type1"
(EE) Failed to load module "type1" (module does not exist, 0)
(II) LoadModule: "freetype"
(WW) Warning, couldn't open module freetype
(II) UnloadModule: "freetype"
(EE) Failed to load module "freetype" (module does not exist, 0)
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
compiled for 1.6.1.901, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension SELinux
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
compiled for 1.6.1.901, module version = 1.0.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "extmod"
(II) Reloading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Loading extension SELinux
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Server Extension
(II) NVIDIA GLX Module 190.18 Wed Jul 22 19:06:03 PDT 2009
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
compiled for 1.6.1.901, module version = 1.13.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions//libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
compiled for 1.6.1.901, module version = 1.0.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Video Driver
(II) NVIDIA dlloader X Driver 190.18 Wed Jul 22 18:37:18 PDT 2009
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 04@00:00:0
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules//libfb.so
(II) Module fb: vendor="X.Org Foundation"
compiled for 1.6.1.901, module version = 1.0.0
ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "wfb"
(II) LoadModule: "wfb"
(II) Loading /usr/lib/xorg/modules//libwfb.so
(II) Module wfb: vendor="X.Org Foundation"
compiled for 1.6.1.901, module version = 1.0.0
ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(II) resource ranges after probing:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[5] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[6] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[7] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[8] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[9] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[10] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[11] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[12] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[13] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[14] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[15] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[16] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[17] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[18] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[19] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[20] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[21] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
[22] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[23] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NoLogo" "on"
(**) NVIDIA(0): Option "AddARGBGLXVisuals" "True"
(**) NVIDIA(0): Option "DisableGLXRootClipping" "True"
(**) Aug 01 09:56:27 NVIDIA(0): Enabling RENDER acceleration
(II) Aug 01 09:56:27 NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) Aug 01 09:56:27 NVIDIA(0): enabled.
(EE) Aug 01 09:56:28 NVIDIA(0): Failed to initialize the NVIDIA graphics device PCI:4:0:0.
(EE) Aug 01 09:56:28 NVIDIA(0): Please check your system's kernel log for additional error
(EE) Aug 01 09:56:28 NVIDIA(0): messages and refer to Chapter 8: Common Problems in the
(EE) Aug 01 09:56:28 NVIDIA(0): README for additional information.
(EE) Aug 01 09:56:28 NVIDIA(0): Failed to initialize the NVIDIA graphics device!
(II) UnloadModule: "nvidia"
(II) UnloadModule: "wfb"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.
#########################################################
#########################################################


xorg.conf:


#########################################################

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder63) Mon May 19 00:33:37 PDT 2008

# Xorg configuration created by pyxf86config


Section "Files"
# RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "/usr/share/fonts/default/Type1"


EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "dri"
Load "extmod"
Load "glx"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# keyboard added by rhpxl
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"
Option "XkbVariant" "nodeadkeys"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "IIyama"
ModelName "ProLite E2403WS"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8800 GT"
EndSection


Section "Screen"

Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "NoLogo" "on"
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection


Section "Extensions"
Option "Composite" "enable"
EndSection
 

Lesen sie die antworten

#1 Rolf Magnus
01/08/2009 - 16:15 | Warnen spam
Richard Ruhland wrote:

habe sein neuesten ein Problem mit NVIDIA (Prob. Treiber von nvidia.com)
unter fedora11. Seit ich die Updates von Fedora11 eingespielt habe,
bekommen ich den nvidia Treiber nicht mehr zum laufen, Fehlermeldungen in
Xorg.0.log sind die Folge.


(EE) Aug 01 09:56:28 NVIDIA(0): Failed to initialize the NVIDIA graphics device PCI:4:0:0.
(EE) Aug 01 09:56:28 NVIDIA(0): Please check your system's kernel log for additional error
(EE) Aug 01 09:56:28 NVIDIA(0): messages and refer to Chapter 8: Common Problems in the
(EE) Aug 01 09:56:28 NVIDIA(0): README for additional information.



Hast du das mal gemacht?
Eine Möglichkeit wàre, daß dein Kernel-Modul nicht zum X-Modul paßt oder
kein nvidia-Kernelmodul geladen ist.

Ähnliche fragen