ODER in SUMMENPRODUKT funktioniert nicht

26/08/2008 - 18:55 von Heinz Müller | Report spam
Hallo Zusammen,

habe ein Problem bei einer ODER-Abfrage.

Variante 1
=SUMMENPRODUKT(((LINKS(Server!Z2:Z350;3))<>"SUN")*(Server!AA2:AA350=H361)*(ODER(Server!AG2:AG350="Server";Server!AG2:AG350="Zonen-Server")))

Variante 2 ohne ODER
=SUMMENPRODUKT(((LINKS(Server!Z2:Z350;3))<>"SUN")*(Server!AA2:AA350=H361)*(Server!AG2:AG350="Server"))

Bis Z2Z350 <>"SUN" UND AA2:AA350=H361 sind beide Varianten identisch: Ich
erhalte 14 Zeilen

Bei Variante 2 erhàlt man zusàtzlich mit Server!AG2:AG350="Server" insgesamt
3 Zeilen

Bei Variante 1 erhàlt man zusàtzlich mit
ODER(Server!AG2:AG350="Server";Server!AG2:AG350="Zonen-Server"))) insgesamt
14 Zeilen.
Das ist aber, wenn ich das manuell in der Tabelle nachschaue nicht
nachvollziehbar. Anscheinend funktioniert das ODER nicht korrekt.
Es sollten ebenfalls nur 3 herauskommen.

Generell soll die Abfrage so sein:

Zeige mir die Anzahl der gefundenen Treffer wenn:
"Server<> SUN" _UND_ "Wartung=unklar" _UND_ ( Geràt=Server _ODER_
Geràt=Zonen-Server)

"Wartung=unklar" entspricht dabei "Server!AA2:AA350=H361"

Was leider gar nicht funktioniert ist sowas: Server!AG2:AG350="*Server*"
Das mit dem * geht wohl nicht, oder? Sonst könnte ich mir das ODER sparen.

Kennt jemand den Trick mit dem richtigen ODER?

Danke!

Gruß
Heinz
 

Lesen sie die antworten

#1 Melanie Breden
26/08/2008 - 19:10 | Warnen spam
Hallo Heinz,

"Heinz Müller" schrieb:
habe ein Problem bei einer ODER-Abfrage.

Generell soll die Abfrage so sein:

Zeige mir die Anzahl der gefundenen Treffer wenn:
"Server<> SUN" _UND_ "Wartung=unklar" _UND_ ( Geràt=Server _ODER_
Geràt=Zonen-Server)



für eine ODER-Prüfung musst du statt einer Multiplikation eine Addition der
beidenTerme vornehmen.
Ich habe die Formel jetzt nicht getestet, aber so sollte sie funktionieren:

=SUMMENPRODUKT(((LINKS(Server!Z2:Z350;3))<>"SUN")*(Server!AA2:AA350=H361)*
((Server!AG2:AG350="Server")+(Server!AG2:AG350="Zonen-Server")))


Mit freundlichen Grüssen
Melanie Breden

- Microsoft MVP für Excel -
www.melanie-breden.de
Das Excel-VBA Codebook 2007 http://tinyurl.com/2nwvod

Ähnliche fragen