OOo 2.3 scheitert (bisher) bei mir an einer simplen Aufgabe

18/09/2007 - 14:28 von Burkhard Schultheis | Report spam
Ich soll für einen Kunden einen ganz einfachen Report aus einer
DB2-Tabelle erstellen. Ich dachte, dass sei mit OOo 2.3 ganz einfach.
Aber weit gefehlt. :-(

Die Aufgabenstellung: Zunàchst wollte ich nur mal ein paar Zeilen aus
meiner Testtabelle darstellen. Die hat folgenden Aufbau:

Startzeitpunkt (Timestamp), Anfangshöhe (Decimal 4,2), Stoppzeitpunkt
(Timestamp), Stopphöhe (Decimal 4,2)

Zuerst habe ich es mal mit einem Tabellendokument probiert:
Daten -> Datenpilot -> Aufrufen -> In OpenOffice.org angemeldetet
Datenquelle -> die Datenbank und die Tabelle ausgewàhlt -> Alle Spalten
in die Zeilenfelder gezogen -> OK

Und das Ergebnis: Die Überschriften sehen so aus, wie ich es erwartet
hatte. Aber die Felder mit den Zeiten sind leer (nebenbei: Die
Rechtschreibprüfung kennt "Zeiten" nicht), d.h. in 3 der 4 Zellen steht
"(leer)", eine Zelle ist wirklich ganz leer, und die Nachkommastellen
sind 0, wenn ich sie sichtbar mache, obwohl die Werte nach dem Komma
teilweise verschieden von 0 sind. Ganz abgesehen davon finde ich die
Beschriftung der letzten Zeile mit "Gesamt Ergebnis" blamabel für ein
Officepaket. :-(

Den zweiten Versuch habe ich dann mit dem Sun Report Builder gemacht.
Auch der zeigt mir als Nachkommastellen immer Nullen an. Kommt OOo mit
dem Datentyp Decimal von DB2 V9.1 nicht klar?

Oder habe ich da etwas falsch gemacht?

Grüße,
Burkhard
A: Weil es die Lesbarkeit des Textes verschlechtert.
F: Warum ist TOFU so schlimm?
A: TOFU
F: Was ist das größte Ärgernis im Usenet?
 

Lesen sie die antworten

#1 Regina Henschel
18/09/2007 - 14:56 | Warnen spam
Hallo Burkhard,

Burkhard Schultheis schrieb:
Ich soll für einen Kunden einen ganz einfachen Report aus einer
DB2-Tabelle erstellen. Ich dachte, dass sei mit OOo 2.3 ganz einfach.
Aber weit gefehlt. :-(

Die Aufgabenstellung: Zunàchst wollte ich nur mal ein paar Zeilen aus
meiner Testtabelle darstellen. Die hat folgenden Aufbau:

Startzeitpunkt (Timestamp), Anfangshöhe (Decimal 4,2), Stoppzeitpunkt
(Timestamp), Stopphöhe (Decimal 4,2)

Zuerst habe ich es mal mit einem Tabellendokument probiert:
Daten -> Datenpilot -> Aufrufen -> In OpenOffice.org angemeldetet
Datenquelle -> die Datenbank und die Tabelle ausgewàhlt -> Alle Spalten
in die Zeilenfelder gezogen -> OK

Und das Ergebnis: Die Überschriften sehen so aus, wie ich es erwartet
hatte. Aber die Felder mit den Zeiten sind leer (nebenbei: Die
Rechtschreibprüfung kennt "Zeiten" nicht), d.h. in 3 der 4 Zellen steht
"(leer)", eine Zelle ist wirklich ganz leer, und die Nachkommastellen
sind 0, wenn ich sie sichtbar mache, obwohl die Werte nach dem Komma
teilweise verschieden von 0 sind. Ganz abgesehen davon finde ich die
Beschriftung der letzten Zeile mit "Gesamt Ergebnis" blamabel für ein
Officepaket. :-(



Werden die Werte richtig angezeigt, wenn du in der Datenbank selbst die
Tabelle als Tabelle öffnest; werden sie richtig angezeigt, wenn du ein
Formular mit einem Tabellen-Kontrollfeld benutzt?

Welches Betriebssystem? Welche Anbindung?


Den zweiten Versuch habe ich dann mit dem Sun Report Builder gemacht.
Auch der zeigt mir als Nachkommastellen immer Nullen an. Kommt OOo mit
dem Datentyp Decimal von DB2 V9.1 nicht klar?



Es ist nicht klar, ob OOo Schwierigkeiten mit dem Datentyp hat oder ob
dies schon im Datenbanktreiber geschieht. Wenn du mit einer Testtabelle
arbeitest, probiere doch die anderen Gleitkommaformate einfach mal aus.


Oder habe ich da etwas falsch gemacht?



Weiß nicht, dazu musst du uns noch etwas mehr mitteilen. Da ich hier
kein DB2 habe, kann ich es aber auch nicht ausprobieren.

mfG
Regina

Ähnliche fragen