openSuse 10.3 und avm fritcard usb sl

03/11/2007 - 15:55 von Johann Letzel | Report spam
In der c't 22/07 lag openSuse 10.3 bei und ich wollte es mal wieder
wagen Linux auszuprobieren ...

Die Installtion lief soweit ganz gut aber mit meinem USB-DSL-Modem
klappts nicht so. Das Geràt wurde erkannt aber die Einwahl mit KInternet
geht nicht.

Ich habe auch schon die passenden RPMs von http://opensuse.foehr-it.de/
runtergeladen und installiert:

fcdslslusb-fw-3.11-1.i586.rpm
fcdslslusb-kmp-default-0.1_2.6.22.5_31-0.i586.rpm

damit kann sich das Modem immerhin schon mit der Vermittlungsstelle
synchronisieren (USB- und DSL-Lampe leuchten).

boot.msg bringt:

<6>fcdslslusb: AVM FRITZ!Card DSL SL USB driver, revision 0.4.4
<6>fcdslslusb: (fcdslslusb built on Oct 8 2007 at 12:44:20)
<6>fcdslslusb: -- 32 bit CAPI driver --
<6>fcdslslusb: Loading...
<5>kcapi: Controller [001]: fcdslslusb-0002 attached
<6>usbcore: registered new interface driver fcdslslusb
<6>fcdslslusb: Loaded.
<6>ACPI: PCI Interrupt 0000:02:0c.0[A] -> GSI 20 (level, low) -> IRQ 22
<6>snd-ca0106: Model 1002 Rev 00000000 Serial 10021102
<6>fcdslslusb: Using VCC/VPI/VCI = 0x1/0x1/0x20
<6>fcdslslusb: Stack version 3.11-05
<5>kcapi: card [001] "fcdslslusb-0002" ready.

capiinfo bringt:

Number of Controllers : 1
Controller 1:
Manufacturer: AVM GmbH
CAPI Version: 2.0
Manufacturer Version: 3.11-05 (49.21)
Serial Number: 0000000
BChannels: 1
Global Options: 0x00000001
internal controller supported
B1 protocols support: 0x10000000
B2 protocols support: 0x40000002
Transparent
B3 protocols support: 0x40000001
Transparent

0100
0100
01000000
00000010
02000040
01000040
00000000 00000000 00000000 00000000 00000000 00000000
01000001 00020000 00000000 00000000 00000000

und KINTERNET bringt nach der Einwahl:

SuSE Meta pppd (smpppd-ifcfg), Version 1.59 on darkruler.
Status is: disconnected
trying to connect to smpppd
connect to smpppd
Status is: disconnected
Status is: connecting
pppd[0]: Plugin capiplugin.so loaded.
pppd[0]: capiplugin: $Revision: 1.36 $
pppd[0]: capiconn: 1.13
pppd[0]: Plugin passwordfd.so loaded.
pppd[0]: capiplugin: phase serialconn.
pppd[0]: controller 1: listen_change_state state=1 event=1 ????
pppd[0]: controller 1: listen_change_state state=1 event=1 ????
pppd[0]: capiplugin: leased line (adslpppoe)
pppd[0]: controller 1: listen_change_state state=0 event=3 ????
pppd[0]: controller 1: listen_change_state state=0 event=3 ????
pppd[0]: got CONNECT_CONF from controller 0x2 ???
pppd[0]: capiplugin: leased line (adslpppoe)
pppd[0]: got CONNECT_CONF from controller 0x2 ???
pppd[0]: capiplugin: leased line (adslpppoe)
pppd[0]: got CONNECT_CONF from controller 0x2 ???

und wiederholt die letzten beiden Zeilen immer wieder ...

Das DSL-Geràt habe ich mit den Einstelungen

PPP-Modus: CAPI für ADSL
Activate device: Manuell
Aktiviere Kontrolle über Gerà€t für nicht-root Nutzer über KInternet

eingerichtet.

Sonst habe ich keine zusàtzlich AVM-Software eingespielt.

Woran kanns noch liegen ?

Ich habe auch noch eine AVM ISDN-Karte installiert, die ich aber noch
nicht eingerichtet habe weil mir momentan DSL wichtiger ist.

Vielen Dank im Voraus.

MfG

Johann Letzel
 

Lesen sie die antworten

#1 Heiko Nocon
03/11/2007 - 18:58 | Warnen spam
Johann Letzel wrote:

[fcdslslusb]

Ich kann mich nicht mehr genau erinnern, aber mir scheint, daß in den
Kernelausgaben auch das Laden der Firmware zu sehen sein müßte, ist es
aber in dem von dir geposteten nicht.

Deswegen vermute ich, daß du die Konfigurationsdatei dafür nicht passend
bearbeitet hast oder das die Firmware überhaupt fehlt. Poste mal deine
/etc/capi.conf

BTW: Hast du mal drdsl probiert? Was sagt das?

Ähnliche fragen