Forums Neueste Beiträge
 

OpenSUSE 11.1 KDE Paketchaos

01/01/2010 - 22:51 von Marcus Woletz | Report spam
Hallo Leute,

ich möchte OpenSUSE 1..1 von KDE 4.1.3 auf KDE 4.3.4 updaten. Leider
sitze ich jetzt schon seit Stunden an der Kiste und komme nicht weiter.

Problem: Wie stelle ich das am einfachsten an, so dass mein System nach
dem Update noch làuft?

Ich habe bereits die entsprechenden Repositories eingehàngt und alte
gelöscht. Dann in YaST die installierten durch die neuen Versionen
ersetzt. Dabei ergeben sich nun unzàhlige nicht auflösbare
Abhàngigkeiten. Abgesehen von einer libgps, die ich nirgendwo in den
repos finden kann, gibt es wohl ein Namensproblem. Auf meiner aktuellen
Installation ist z.B. ein Paket "kde4-kdm 4.1.3" installiert.
In den neuen repos gibt es jetzt nur noch ein "kdm 4.3.4". So ist das
mit unzàhligen Paketen, so dass die alten Pakete nicht durch die neuen
ersetzt werden, die alten Pakete noch die 4.1.3er Runtime benötigen, die
ja beim Updaten ausgetauscht werden soll.

Da irgendetwas einfach zu testen, scheint mir ein Himmelfahrtskommando.
Und hunderte Pakete manuell abgleichen kann eigentlich auch nicht
funktionieren.

Was also ist zu tun? Hat schon jemand von 4.1.3 auf 4.3.4 umgestellt.

Eigentlich wollte ich ja gar nicht umstellen, aber seit zwei Tagen, seit
ich einige Pakete installiert habe, zieht der Prozess "Plasma" über 40%
CPU-Zeit, die Fenster stehen ohne Rahmen und Titelleiste da und KDE ist
einfach völlig vermurkst. Die Pakete (zumindest die direkt
installierten) hatten nichts mit KDE zu tun. Ich hatte Probleme mit
völlig vermurkster Audiowiedergabe bei Flash-Filmen (dieses Problem ist
übrigens auch noch nicht gelöst: das neue 10er Flash-Plugin wird vom
Broswer nicht erkannt).

Oh mann, wann wird Linux endlich erwachsen: eigentlich kann man nirgends
am System drehen, ohne dass das System völlig vermurkst ist.


Bitte Bitte Bitte, liebe Entwickler, lasst die Versionen wie sie sind
und beseitigt die Fehler. Bitte!

Ja, bei Gelegenheit werde ich mich am Projekt beteiligen. Es gibt ja
genügend zu tun. Ich sage nur: Audio...

Vielen Dank schon an dieser Stelle für Eure Unterstützung!

ciao

Marcus
 

Lesen sie die antworten

#1 Arno Lutz
01/01/2010 - 23:19 | Warnen spam
Marcus Woletz schrieb:
Eigentlich wollte ich ja gar nicht umstellen, aber seit zwei Tagen, seit
ich einige Pakete installiert habe, zieht der Prozess "Plasma" über 40%
CPU-Zeit, die Fenster stehen ohne Rahmen und Titelleiste da und KDE ist
einfach völlig vermurkst. Die Pakete (zumindest die direkt



das hatte ich auch schon.
lösche oder umbenenne mal
-plasma-desktoprc
-plasma-desktop-appletsrc
-plasmarc
in ~/.kde4/share/config/

danach wirst du wohl deinen Desktop wieder einrichten müssen, Plasma wird aber keine
40% mehr brauchen.

Gruß
Arno

Die kürzesten Wörter, nàmlich "ja" und "nein" erfordern das meiste Nachdenken.
(Pythagoras)

Ähnliche fragen