openSUSE 11.3 x86_64 und kde 4.5 - geht hier nicht (mehr)

25/10/2010 - 13:01 von Kyek, Andreas, VF-DE | Report spam
Hallo,

leichtsinnig wie man manchmal ist habe ich heute einen
Rechner von 11.3 32bit auf 11.3 64 bit "gehoben".

Mittlerweile sind alle repositories eingebunden; der Rechner
làuft im RL3 ohne Probleme. Ein "zypper dup" will nichts mehr
leisten; KDE kommt vom KDE Release 4.5 Repository.

Ein rpm --verify für alle Pakete zeigt mir keine Auffàlligkeiten.
Trotzdem weigert sich der Rechner KDE4 zu starten.

Ein init 5 bringt mir den login-Screen; nach einer Eingabe
lande ich wieder hier.
Ein startx von der Konsole im RL3 bringt mir wieder die
Konsole.

Dabei sehe ich
a) in der Konsole:
...
startked: Starting up
Connection do deprecated Signal QDBusConnectionInterface:: ...
kded(<PID>): Communication problem with "kded" , it probably crashed
Error message was: "org.freedesktop.DBus.Error.ServiceUnknown":\
"The name org.kde.kded was not provided by any .service file"

b) in /v/l/m:
... kernel ...kded[<PID>] trap divide error ip:xx sp:xx error:0 \
in libkdecore.so.5.5.0
... kernel ...kcminit_startup[<PID>] trap divide error ip:xx sp:xx error:0 \
in libkdecore.so.5.5.0
.. kernel ...ksmserver[<PID>] trap divide error ip:xx sp:xx error:0 \
in libkdecore.so.5.5.0

Irgendetwas scheint mit der lib nicht zu gehen, oder?

Ein "locate libkdecore.so.5.5.0" bringt mir
/usr/lib/libkdecore.so.5.5.0
/usr/lib64/libkdecore.so.5.5.0

Die Pakete dazu sind:
libkdecore-4.5.2-10.1
libkdecore-32bit-4.5.2-10.1

Was geht hier schief?

Andreas

PS: heute morgen in der 32 bit Version ging noch alles!
Um die Liste abzubestellen, schicken Sie eine Mail an:
opensuse-de+unsubscribe@opensuse.org
Um eine Liste aller verfuegbaren Kommandos zu bekommen, schicken
Sie eine Mail an: opensuse-de+help@opensuse.org
 

Lesen sie die antworten

#1 Sebastian Siebert
25/10/2010 - 13:37 | Warnen spam
Hallo Andreas,

Am 25.10.2010 13:01, schrieb Kyek, Andreas, VF-DE:
leichtsinnig wie man manchmal ist habe ich heute einen
Rechner von 11.3 32bit auf 11.3 64 bit "gehoben".



Normalerweise würde ich jetzt sagen: "Never change a running system"

Mittlerweile sind alle repositories eingebunden; der Rechner
làuft im RL3 ohne Probleme. Ein "zypper dup" will nichts mehr
leisten; KDE kommt vom KDE Release 4.5 Repository.



Prüfe bitte erst, ob du wirklich alle Pakete auf 64-bit aktualisiert hast:

# rpm -qa --qf '%{name}-%{version} => %{arch}' | grep -E 'i?86' | sort

Falls der o.g. Befehl noch einige 32-bit Pakete ausspuckt, dann solltest
du erst mal diese Pakete manuell umstellen.

Danach schauen wir mal weiter.

PS: heute morgen in der 32 bit Version ging noch alles!



Ja ne, ist klar. ;-)

Gruß Sebastian - openSUSE Member (Freespacer)
Webseite/Blog: <http://www.sebastian-siebert.de>
Wichtiger Hinweis zur openSUSE Mailing Liste:
<http://de.opensuse.org/OpenSUSE_Mai...quette>
Um die Liste abzubestellen, schicken Sie eine Mail an:
opensuse-de+
Um eine Liste aller verfuegbaren Kommandos zu bekommen, schicken
Sie eine Mail an: opensuse-de+

Ähnliche fragen