[OpenSuSE 13.2]: MariaDB läßt sich von 10.0.20 nicht auf 10.1.5 updaten

28/06/2015 - 17:42 von Mexx Headroooommm | Report spam
Hallo erstmal,

heute versuchte ich mittels 'zypper dup' die MariaDB 10.0.20 auf 10.1.5
upzugraden was aber leider fehlschlàgt. leider konnte ich bisher
nichts 'ergooglen' hat jemand ein Tipp?

Als Meldnug bekomme ich:
idefix:/var/lib/mysql # rcmysql status
mysql.service - MySQL server
Loaded: loaded (/usr/lib/systemd/system/mysql.service; enabled)
Active: failed (Result: exit-code) since Sun 2015-06-28 17:10:40
CEST; 13min ago
Process: 2393 ExecStartPre=/usr/lib/mysql/mysql-systemd-helper upgrade
default (code=exited, status=1/FAILURE)
Process: 2386 ExecStartPre=/usr/lib/mysql/mysql-systemd-helper install
default (code=exited, status=0/SUCCESS)

Jun 28 17:10:40 idefix mysql-systemd-helper[2393]: Checking MySQL
configuration for obsolete options...
Jun 28 17:10:40 idefix mysql-systemd-helper[2393]: Trying to run upgrade
of MySQL databases...
Jun 28 17:10:40 idefix mysql-systemd-helper[2393]: Stale files from
previous upgrade detected, cleaned them up
Jun 28 17:10:40 idefix mysql-systemd-helper[2393]: Can't secure tmp dir
'/var/tmp/mysql-protected.wHeIXT'
idefix:/var/lib/mysql #

und.. ich bekomme auch:

17:10:40 CEST. --
Jun 28 17:07:45 idefix mysql-systemd-helper[2263]: Trying to run upgrade
of MySQL databases...
Jun 28 17:07:45 idefix mysql-systemd-helper[2263]: Stale files from
previous upgrade detected, cleaned th
Jun 28 17:07:45 idefix mysql-systemd-helper[2263]: Can't secure tmp dir
'/var/tmp/mysql-protected.2yTm1r'
Jun 28 17:09:34 idefix su[2325]: (to root) mexx on pts/2
Jun 28 17:09:34 idefix su[2325]: pam_unix(su:session): session opened
for user root by mexx(uid00)
Jun 28 17:09:40 idefix kernel: SFW2-INext-ACC-TCP IN=enp0s4 OUTMAC=<meine MAC-Adresse>
Jun 28 17:10:40 idefix mysql-systemd-helper[2393]: Checking MySQL
configuration for obsolete options...
Jun 28 17:10:40 idefix mysql-systemd-helper[2393]: Trying to run upgrade
of MySQL databases...
Jun 28 17:10:40 idefix mysql-systemd-helper[2393]: Stale files from
previous upgrade detected, cleaned th
Jun 28 17:10:40 idefix mysql-systemd-helper[2393]: Can't secure tmp dir
'/var/tmp/mysql-protected.wHeIXT'


Ein "downgraden" auf 10.0.20 funktionierte noch ..
ich hab zwar was gefunden jedoch kann ich leider kein spanisch...
http://www.forosuse.org/forosuse/sh....php?t2690

Gruß
-Markus
 

Lesen sie die antworten

#1 Dieter Intas
28/06/2015 - 21:32 | Warnen spam
Mexx Headroooommm schrieb:

Hallo erstmal,

heute versuchte ich mittels 'zypper dup' die MariaDB 10.0.20 auf 10.1.5
upzugraden was aber leider fehlschlàgt. leider konnte ich bisher
nichts 'ergooglen' hat jemand ein Tipp?

Als Meldnug bekomme ich:
idefix:/var/lib/mysql # rcmysql status
mysql.service - MySQL server
Loaded: loaded (/usr/lib/systemd/system/mysql.service; enabled)
Active: failed (Result: exit-code) since Sun 2015-06-28 17:10:40
CEST; 13min ago
Process: 2393 ExecStartPre=/usr/lib/mysql/mysql-systemd-helper
upgrade
default (code=exited, status=1/FAILURE)
Process: 2386 ExecStartPre=/usr/lib/mysql/mysql-systemd-helper
install
default (code=exited, status=0/SUCCESS)

Jun 28 17:10:40 idefix mysql-systemd-helper[2393]: Checking MySQL
configuration for obsolete options...
Jun 28 17:10:40 idefix mysql-systemd-helper[2393]: Trying to run
upgrade of MySQL databases...
Jun 28 17:10:40 idefix mysql-systemd-helper[2393]: Stale files from
previous upgrade detected, cleaned them up

Jun 28 17:10:40 idefix mysql-systemd-helper[2393]: Can't secure tmp dir
'/var/tmp/mysql-protected.wHeIXT'
idefix:/var/lib/mysql #

und.. ich bekomme auch:

17:10:40 CEST. --
Jun 28 17:07:45 idefix mysql-systemd-helper[2263]: Trying to run
upgrade of MySQL databases...
Jun 28 17:07:45 idefix mysql-systemd-helper[2263]: Stale files from
previous upgrade detected, cleaned th
Jun 28 17:07:45 idefix mysql-systemd-helper[2263]: Can't secure tmp dir
'/var/tmp/mysql-protected.2yTm1r'
Jun 28 17:09:34 idefix su[2325]: (to root) mexx on pts/2
Jun 28 17:09:34 idefix su[2325]: pam_unix(su:session): session opened
for user root by mexx(uid00)
Jun 28 17:09:40 idefix kernel: SFW2-INext-ACC-TCP IN=enp0s4 OUT>MAC=<meine MAC-Adresse>
Jun 28 17:10:40 idefix mysql-systemd-helper[2393]: Checking MySQL
configuration for obsolete options...
Jun 28 17:10:40 idefix mysql-systemd-helper[2393]: Trying to run
upgrade of MySQL databases...
Jun 28 17:10:40 idefix mysql-systemd-helper[2393]: Stale files from
previous upgrade detected, cleaned th



Bis hier alles Normal ... dann ...

Jun 28 17:10:40 idefix mysql-systemd-helper[2393]: Can't secure tmp dir
'/var/tmp/mysql-protected.wHeIXT'



Kann tmp dir nicht sichern
'/ var / tmp / mysql-protected.wHeIXT'

Scheinbar Probleme mit sichern auf den Pfad ... warum auch immer!
Ist der Pfad vielleicht irgendwie besonders geschützt?

Ein "downgraden" auf 10.0.20 funktionierte noch ..
ich hab zwar was gefunden jedoch kann ich leider kein spanisch...
http://www.forosuse.org/forosuse/sh....php?t2690



Derjenige hat auch Probleme und benötigt Hilfe ...

Vielleicht bringt Dich das weiter ...
https://mariadb.org/

Ähnliche fragen