[OpenSuse] Rechner bleibt beim Booten hängen

24/09/2010 - 19:32 von Rick Szabo | Report spam
Heute hat mich ein Problem ereilt, bei dem ich echt auf dem Schlauch stehe.

Ich habe zwei identische Rechner, auf denen einige Serverdienste laufen.
Beide Rechner laufen mit OpenSuse 11.3.
Hintergrund ist, dass auf dem einen (Test-)Rechner neue Dienste o.à.
immer erst ausgetestet werden und wenn es dann so làuft, wie ich will,
werden sie auf dem anderen (Produktiv)-Rechner in Betrieb genommen.

Heute musste unser Energieversorger für eine Stunde den Strom
abschalten, deshalb wurden beide Rechner nach langer Zeit wieder mal
runtergefahren.

Nach dem Einschalten ging der Produktivrechner problemlos, aber der
Testrechner bleibt beim Booten hàngen. Die Startscripte werden
abgearbeitet und nach dem letzten "done" passiert nichts mehr. Es kommt
kein Login-Prompt, TTY2 - TTY6 sind nicht vorhanden, ein Remote-Login
über SSH funktioniert auch nicht.
Einziger erkennbarer Fehler war ein "failed" bei Avahi, "exit status of
parent /usr/bin/avahi-daemon: 1" (aus dem Gedaechtnis), aber damit hat
mich Google auch nicht wirklich weitergebracht.
Testweise habe ich avahi-daemon und avahi-dnsconfd aus den Startscripts
genommen, dann bleibt das System beim Booten eben nach dem Start von SMB
stehen. Nehme ich das auch raus, bleibt das System nach dem Start von
Clamav stehen. Usw.
Es sieht also so aus, als wàre das Problem nicht bei den Startscripts,
sondern exakt danach.

Irgendeine Idee, wo ich suchen soll? (Klar könnte ich den Rechner
einfach neu aufsetzen und es wàre nix verloren, aber irgendwie wurmt
mich das...)

Es ist übrigens kein Freeze, der Rechner reagiert auf Tastatureingaben
zumindest soweit, dass er sie am Bildschirm anzeigt. Die Festplatte
rödelt noch eine Zeit lang und dann nur noch sporadisch.

Danke für alle Ideen, ich weiss momentan wirklich nicht, wo ich ansetzen
soll.

Bye
Rick
 

Lesen sie die antworten

#1 Ansgar Strickerschmidt
27/09/2010 - 10:38 | Warnen spam
Also schrieb Rick Szabo:

Es ist übrigens kein Freeze, der Rechner reagiert auf Tastatureingaben
zumindest soweit, dass er sie am Bildschirm anzeigt. Die Festplatte
rödelt noch eine Zeit lang und dann nur noch sporadisch.

Danke für alle Ideen, ich weiss momentan wirklich nicht, wo ich ansetzen
soll.



Ich vermute mal, da làuft im Hintergrund noch der routinemàßige
Festplattencheck... lass ihn einfach mal zwei bis drei Stunden (oder gar
lànger...) in Ruhe werkeln und schau dann nochmal.
Dank upstart geht das ja heute alles weitestgehend parallelisiert.

Ansgar

*** Musik! ***

Ähnliche fragen