openvpn Probleme

03/02/2008 - 20:34 von Walter Lehmann | Report spam
Hallo zusammen,

ich habe ein kleines Netzwerk am laufen. Das Gateway ist ein Hardware
Router mit DynDns client. Ich habe mich bei DynDns registriert und kann
mich übers Inet anpingen. Hinter dem Gateway steht ein Server auf dem
openvpn làuft. Openvpn habe ich wie in
http://wiki.ubuntuusers.de/OpenVPN?...openvpn%29 beschrieben
eingerichtet.

Jetzt zur ersten Frage: Ich habe den vpn Server aus meinem Lan mit
nmap gescannt und sehe keinen offenen udp port 1194 (in der openvpn conf
habe ich udp 1194 eingerichtet). Wie kann ich prüfen, ob der port offen
ist oder nicht?

Auf meinem mac habe ich den vpn client tunnelblick installiert und dort
die entsprechenden Zertifikate importiert. Wenn ich aus dem lan den vpn
server kontaktiere sehe ich in den logs keine Fehlermeldung o. à. und im
Finder tauchen z. B. meine samba Server doppelt auf. Ich gehe davon aus,
das im lan das vpn ordnungsgemàß arbeitet. Übers Inet klappt das leider
nicht. Muß ich auf meinem gateway eine statische route setzen?

Für eure Antworten schon mal im vorraus vielen Dank,

Walter
 

Lesen sie die antworten

#1 Sebastian Kaps
03/02/2008 - 21:31 | Warnen spam
Walter Lehmann schrieb:

Jetzt zur ersten Frage: Ich habe den vpn Server aus meinem Lan mit
nmap gescannt und sehe keinen offenen udp port 1194 (in der openvpn conf
habe ich udp 1194 eingerichtet). Wie kann ich prüfen, ob der port offen
ist oder nicht?



Hast Du nmap mit der -sS Option für UDP verwendet? Ist auf dem Router
Port-Forwarding von 1194/UDP auf das Gateway eingerichtet?

Muß ich auf meinem gateway eine statische route setzen?



Ja, Du mußt das VPN-Netz auf das OpenVPN-Gateway routen.

Ciao, Sebastian

Ähnliche fragen