Oracle Timestamp-Feld macht Probleme in Access

17/04/2009 - 09:56 von Markus Misiak | Report spam
Hallo zusammen,

ich möchte Tabellen mit dem MS-ODBC-Treiber in Access verknüpfen. Dies
funktioniert soweit auch ganz gut. Beim Öffnen der Tabellen in Access
kommt dann aber die Fehlermeldung "Fehler in der Funktionsreihenfolge
(#0)", die Tabelle wird geöffnet, aber alle Datenfelder enthalten "#Name?".

Ich habe versucht, die Sache weiter Einzugrenzen und eine Abfrage über
diese verknüpfte Tabelle gelegt. Dabei hat sich herausgestellt, dass das
Problem auftritt, sobald die Abfrage auf ein Oracle-Timestamp-Feld
stößt. Lasse ich diese Felder aus der Abfrage heraus, funktioniert die
Sache. Nur leider benötige ich die Werte dieser Felder auch. Ich habe
auch schon versucht, in der Abfrage den Wert in ein Datum zu
konvertieren, aber leider ohne Erfolg - sobald das Feld auch nur in
einer Funktion auftaucht kommt der Fehler.

Hat hier jemand eine Idee, was ich machen kann? Oracle ist die 10g und
Access ist die Version 2007, jedoch mit einer mdb Datenbank (accdb kommt
im Moment nicht in Frage).

Vielen Dank und viele Grüße

Markus
 

Lesen sie die antworten

#1 Henry Habermacher
17/04/2009 - 10:13 | Warnen spam
Hallo Markus

Markus Misiak wrote:
Hat hier jemand eine Idee, was ich machen kann? Oracle ist die 10g und
Access ist die Version 2007, jedoch mit einer mdb Datenbank (accdb kommt
im Moment nicht in Frage).



Hast Du schon mal mit einem anderen Oracle ODBC Treiber versucht? Vielleicht
mit dem, der von MS mitgeliefert wird.

Gruss
Henry


Los geht's: SEK3 Anmeldung bei www.donkarl.com/?sek
Microsoft MVP Office Access
Keine E-Mails auf Postings in NGs. Danke.
Access FAQ www.donkarl.com

Ähnliche fragen