Ordnen von Merkmalen

05/09/2008 - 11:41 von Holger D. | Report spam
Hallo Zusammen,
ich habe ein Formelproblem und komme dort auf keine Lösung. Es wàre super,
wenn mir dabei jmd. helfen könnte:

Mit der Matrix-Formel:
=WENN(SUMME(WENN('Fragebogen-Kunststoff_Antworten'!AT$1:AT$50="";0;1/ZÄHLENWENN('Fragebogen-Kunststoff_Antworten'!AT$1:AT$50;'Fragebogen-Kunststoff_Antworten'!AT$1:AT$50)))
<
ZEILE('Fragebogen-Kunststoff_Antworten'!AT2);"";INDEX('Fragebogen-Kunststoff_Antworten'!AT:AT;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN('Fragebogen-Kunststoff_Antworten'!AT$1;;;ZEILE($1:$164));'Fragebogen-Kunststoff_Antworten'!AT$1:AT$50)=1;ZEILE($1:$50));ZEILE('Fragebogen-Kunststoff_Antworten'!AT2))))

Vergleiche ich eine Spalte eines Arbeitsblattes und suche mir damit die
einmalig vorkommenen Eintràge heraus. Das funktioniert auch wunderbar.

Nun möchte ich diese Eintràge jedoch auch direkt sortiert haben. (Also von
0,1...0,5 beispielsweise). Der zugrunde liegende Datenbestand ist dabei wild
gewürfelt.

Mit ist klar, dass ich das mit einer zusàtzlichen Spalte und der Funktion
KKleinste durchführen kann. Das bekomme ich ebenfalls hin.

Ich würde das jedoch alles gerne in EINER Formel haben, so dass ich auch
keine zusàtzliche Spalte benötige.

Kennst sich damit jmd. aus und könnte mir kurzfristig helfen??

Das wàre wirklich super nett, denn ich verzweifel langsam daran...

Danke,
Holger
 

Lesen sie die antworten

#1 {Boris}
05/09/2008 - 18:01 | Warnen spam
Hi Holger,

On 5 Sep., 11:41, Holger D. wrote:
Hallo Zusammen,
ich habe ein Formelproblem und komme dort auf keine Lösung. Es wàre super,
wenn mir dabei jmd. helfen könnte:

Mit der Matrix-Formel:
=WENN(SUMME(WENN('Fragebogen-Kunststoff_Antworten'!AT$1:AT$50="";0;1/ZÄHLEN­WENN('Fragebogen-Kunststoff_Antworten'!AT$1:AT$50;'Fragebogen-Kunststoff_An­tworten'!AT$1:AT$50)))
<
ZEILE('Fragebogen-Kunststoff_Antworten'!AT2);"";INDEX('Fragebogen-Kunststof­f_Antworten'!AT:AT;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN('Frageboge­n-Kunststoff_Antworten'!AT$1;;;ZEILE($1:$164));'Fragebogen-Kunststoff_Antwo­rten'!AT$1:AT$50)=1;ZEILE($1:$50));ZEILE('Fragebogen-Kunststoff_Antworten'!­AT2))))

Vergleiche ich eine Spalte eines Arbeitsblattes und suche mir damit die
einmalig vorkommenen Eintràge heraus. Das funktioniert auch wunderbar.

Nun möchte ich diese Eintràge jedoch auch direkt sortiert haben. (Also von
0,1...0,5 beispielsweise). Der zugrunde liegende Datenbestand ist dabei wild
gewürfelt.

Mit ist klar, dass ich das mit einer zusàtzlichen Spalte und der Funktion
KKleinste durchführen kann. Das bekomme ich ebenfalls hin.

Ich würde das jedoch alles gerne in EINER Formel haben, so dass ich auch
keine zusàtzliche Spalte benötige.

Kennst sich damit jmd. aus und könnte mir kurzfristig helfen??

Das wàre wirklich super nett, denn ich verzweifel langsam daran...



=WENN(SUMME(WENN('Fragebogen-Kunststoff_Antworten'!AT$1:AT$50="";0;1/
ZÄHLENWENN('Fragebogen-Kunststoff_Antworten'!AT$1:AT$50;'Fragebogen-
Kunststoff_Antworten'!AT$1:AT
$50)))<ZEILE(A2);"";KKLEINSTE(WENN((ZÄHLENWENN(BEREICH.VERSCHIEBEN('Fragebogen-
Kunststoff_Antworten'!AT$1;;;ZEILE($1:$164));'Fragebogen-
Kunststoff_Antworten'!AT$1:AT$50)=1)*$AT$1:$AT$164;$AT$1:$AT
$164);ZEILE(A1)))

als Arrayformel mit Strg+Shift+Enter abschließen und dann
runterkopieren.

Kleiner Tipp für die Zukunft:
Es wird wesentlich übersichtlicher, wenn Du nicht so mordslange
Blattnamen verwendest. Änder den Blattnamen einfach temporàr in *x*
und poste die Formel dann. Kannst Du ja nachher wieder àndern (Excel
macht das ja automatisch).

Die selbe Formel sieht dann so aus:

=WENN(SUMME(WENN(x!AT$1:AT$50="";0;1/ZÄHLENWENN(x!AT$1:AT$50;x!AT$1:AT
$50)))<ZEILE(A2);"";KKLEINSTE(WENN((ZÄHLENWENN(BEREICH.VERSCHIEBEN(x!AT
$1;;;ZEILE($1:$164));x!AT$1:AT$50)=1)*$AT$1:$AT$164;$AT$1:$AT
$164);ZEILE(A1)))

Grüße Boris

Ähnliche fragen