OS10.3: Grub zickt

02/12/2007 - 15:19 von Alexander Goetzenstein | Report spam
Hallo,
ich habe hier zugegebenermaßen eine nicht ganz alltàgliche Aufteilung
meiner Pestflatte: die erste Partition besetzt der IBM Bootmanager, die
zweite (sda2) lagert Win2000 auf vfat und nennt sie C:, dann folgt sda4,
das /home aufnimmt, sda5 mit swap, sda6 ist / und auf sda7 residiert
OS/2 auf HPFS. Da der IBM Bootmanager weiterhin das Kommando haben soll,
wollte ich Grub in die Partition installieren, von der Linux bootet,
also sda6. Sollte ja eigentlich funktionieren, dachte ich mir. Doch nach
erfolgter Installation startet nicht SuSE, sondern:


GNU GRUB version 0.97 (640K lower / 3072K upper memory)

[ Minimal BASH-like line editing is supported. For the first word, TAB
lists possible command completions. Anywhere else TAB lists the possible
completions of a device/filename. ]
grub> setup --stage2=/boot/grub/stage2 (hd0,5)

Error 12: Invalid device requested
grub> quit




meine fstab sieht so aus:


/dev/disk/by-id/scsi-SATA_ST320423A_2FJ87M2N-part6 / ext3 acl,user_xattr 1 1
/dev/disk/by-id/scsi-SATA_ST320423A_2FJ87M2N-part4 /home ext3 acl,user_xattr 1 2
/dev/disk/by-id/scsi-SATA_ST320423A_2FJ87M2N-part2 /windows/C vfat users,gid=users,umask02,utf8=true 0 0
/dev/disk/by-id/scsi-SATA_ST320423A_2FJ87M2N-part5 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode20,gid=5 0 0
/dev/fd0 /media/floppy auto noauto,user,sync 0 0




Schon mehrfach habe ich mit yast2 versucht, Grub richtig zu
installieren, mit diversen Varianten der Konfig, leider ohne Erfolg
bislang. Gibt es etwas Grundsàtzliches, was ich übersehe?


Gruss
Alex
 

Lesen sie die antworten

#1 Michael Kummer
02/12/2007 - 22:02 | Warnen spam
Alexander Goetzenstein wrote:

Hallo,
ich habe hier zugegebenermaßen eine nicht ganz alltàgliche Aufteilung
meiner Pestflatte: die erste Partition besetzt der IBM Bootmanager, die
zweite (sda2) lagert Win2000 auf vfat und nennt sie C:, dann folgt sda4,
das /home aufnimmt, sda5 mit swap, sda6 ist / und auf sda7 residiert
OS/2 auf HPFS. Da der IBM Bootmanager weiterhin das Kommando haben soll,
wollte ich Grub in die Partition installieren, von der Linux bootet,
also sda6. Sollte ja eigentlich funktionieren, dachte ich mir. Doch nach
erfolgter Installation startet nicht SuSE, sondern:

GNU GRUB version 0.97 (640K lower / 3072K upper memory)

[ Minimal BASH-like line editing is supported. For the first word, TAB
lists possible command completions. Anywhere else TAB lists the
possible completions of a device/filename. ]
grub> setup --stage2=/boot/grub/stage2 (hd0,5)

Error 12: Invalid device requested
grub> quit




meine fstab sieht so aus:

/dev/disk/by-id/scsi-SATA_ST320423A_2FJ87M2N-part6 /
ext3 acl,user_xattr 1 1
/dev/disk/by-id/scsi-SATA_ST320423A_2FJ87M2N-part4 /home
ext3 acl,user_xattr 1 2
/dev/disk/by-id/scsi-SATA_ST320423A_2FJ87M2N-part2 /windows/C
vfat users,gid=users,umask02,utf8=true 0 0
/dev/disk/by-id/scsi-SATA_ST320423A_2FJ87M2N-part5 swap
swap defaults 0 0
proc /proc proc defaults
0 0
sysfs /sys sysfs noauto
0 0
debugfs /sys/kernel/debug debugfs noauto
0 0
usbfs /proc/bus/usb usbfs noauto
0 0
devpts /dev/pts devpts mode20,gid=5
0 0
/dev/fd0 /media/floppy auto noauto,user,sync
0 0




Schon mehrfach habe ich mit yast2 versucht, Grub richtig zu
installieren, mit diversen Varianten der Konfig, leider ohne Erfolg
bislang. Gibt es etwas Grundsàtzliches, was ich übersehe?




was hast du denn als /boot eingetragen?

Michael

Ähnliche fragen