Outlook Anywhere/ Windows 2008

03/11/2009 - 17:22 von Felix Zachlod | Report spam
Hallo!

ich habe hier zwei Domain Controller mit Windows Server 2008. Auf einem
der Rechner habe ich einen Exchange 2007 Standard installiert. Nun
moechte ich Outlook Anywhere konfigurieren. Dazu habe ich RPC over HTTP
installiert und Outlook Anywhere im Exchange Manager freigeschaltet.

Der Zugriff von aussen passiert ueber einen Reverse Proxy Server mit SSL
, intern findet der Zugriff ohne SSL statt. Der externe Hostname, nennen
wir ihn exchange.domain.com zeigt auf den Reverse Proxy, ueber diesen
klappt auch der Zugriff auf OWA einwandfrei. Richte ich nun Outlook 2007
so ein, dass es ueber den RPC- Proxy zugreifen soll, klappt der Zugriff
auf den Exchange Server zwar zumindest intern, rpcinfo zeigt mir aber,
dass der Zugriff ueber TCP/IP erfolgt, nicht jedoch ueber HTTPS. Ob das
nun korrekt ist, weiss ich nicht, jedenfalls habe ich schon andere
Informationen gefunden.

Greife ich nun von extern auf den Server zu, erscheint zumindest der
Login- Dialog und danach erscheint versucht Outlook vergblich die
Verbindung herzustellen, es wird aber auch keine Fehlermeldung
praesentiert. Interessanter Weise ersetzt Outlook den Servernamen in der
Konfiguration des Email Postfaches von "exchange.domain.com" zu
"a.intern.domain.com", welches die interne Repraesentation des Exchange
Servers ist. Stelle ich dies wieder auf 'exchange.domain.com' so ist es
nach der naechsten Verbindung zum Exchange Server wieder
'a.intern.domain.com'.

Hat jemand eine Idee was hier falsch laeuft oder wie ich den Fehler
debuggen kann?

Danke & Gruss,
Felix
 

Lesen sie die antworten

#1 Walter Steinsdorfer [MVP]
03/11/2009 - 19:01 | Warnen spam
Hi,

ich habe hier zwei Domain Controller mit Windows Server 2008. Auf einem
der Rechner habe ich einen Exchange 2007 Standard installiert. Nun moechte
ich Outlook Anywhere konfigurieren. Dazu habe ich RPC over HTTP
installiert und Outlook Anywhere im Exchange Manager freigeschaltet.

Der Zugriff von aussen passiert ueber einen Reverse Proxy Server mit SSL ,
intern findet der Zugriff ohne SSL statt. Der externe Hostname, nennen wir
ihn exchange.domain.com zeigt auf den Reverse Proxy, ueber diesen klappt
auch der Zugriff auf OWA einwandfrei. Richte ich nun Outlook 2007 so ein,
dass es ueber den RPC- Proxy zugreifen soll, klappt der Zugriff auf den
Exchange Server zwar zumindest intern, rpcinfo zeigt mir aber, dass der
Zugriff ueber TCP/IP erfolgt, nicht jedoch ueber HTTPS. Ob das nun korrekt
ist, weiss ich nicht, jedenfalls habe ich schon andere Informationen
gefunden.

Greife ich nun von extern auf den Server zu, erscheint zumindest der
Login- Dialog und danach erscheint versucht Outlook vergblich die
Verbindung herzustellen, es wird aber auch keine Fehlermeldung
praesentiert. Interessanter Weise ersetzt Outlook den Servernamen in der
Konfiguration des Email Postfaches von "exchange.domain.com" zu
"a.intern.domain.com", welches die interne Repraesentation des Exchange
Servers ist. Stelle ich dies wieder auf 'exchange.domain.com' so ist es
nach der naechsten Verbindung zum Exchange Server wieder
'a.intern.domain.com'.

Hat jemand eine Idee was hier falsch laeuft oder wie ich den Fehler
debuggen kann?



fangen wir mal beim Zertifikat an. Hat das SAN-Zertifikat alle relvanten
Namen unter alternate Subject names? Hast du im CAS die Zugriffsurl richtig
konfiguriert bzw. für intern und extern getrennt? Wenn ja sind die Namen +
Netbiosnamen im Certifikat enthalten? Hast du einen Autoconfiguration -
Eintrag im DNS gesetzt/setzten lassen und auch diesen im Zertifikat?

Viele Grüße aus München

Walter Steinsdorfer [MVP]
http://msmvps.com/blogs/wstein

Ähnliche fragen