Outlook Zertifaktfehler nach

21/01/2010 - 18:45 von Lutz Rahe | Report spam
Ich hab z.zt. ein Problem bei einem Kunden, da steh ich jetzt "voll auf dem
Schlauch"

Einige konnte ich lösen (u.a. 800401F Fehler)

Folgende Umgebung
2x DC 2003, 1x mit einer Root CA
1x Exchange 2007 SP1 auf 2003 (mail1.firma-hamburg.de)
1x Exchange 2007 SP2 auf 2008 (mail2.firma-hamburg.de)

beide Server haben ein self-signed Zertifikat welches ja 1Jahr gültig ist.
Outlook 2007 keine Probleme, OWA kommt mit Zertifikatsfehler

Also dachte ich mir, mache ich ein Zertifkat mit einem Alternatename

Dazu habe ich auf beiden Servern folgendes eingegeben:
New-ExchangeCertificate -GenerateRequest -SubjectName "cÞ, o=mail1,
cn=owa.mail1.firma-hamburg.de" -IncludeAcceptedDomains -DomainName
mail1 -includeAutodiscover -privatekeyexportable $true -Path c:\cert.req

Sowohl auf Mail1 als auf Mail2. Beide Anforderungen auf der CA eingereicht,
und downgeloadet.
Mit import-ExchnageCertificate importiert und Enable-ExchangeCertificate die
entsprechenden Services eingebunden

Inn den Zertifikaten, die jetzt mail1 (bzw 2).firma-hamburg.de lauten stehen
als zusàtzliche namen drinnen:
mail1
firma-hamburg.de
firma.de
autodiscover.firma-hamburg.de
autodiscover.firma.de

Die Root CA verteile ich per GPO

Unter OWA gibtŽs jetzt keinen Fehler mehr
Dafür aber im Outlook (2007) beim Start. 2x eine Warnung dass der Name nicht
dem Zertifikat überienstimmt.
Schaue ich mir das Zertifikat an, stimmt aber sowohl der Name als auch die
Zertifikatskette kann aufgelöst werden.

Wo liegt da mein Fehler? Was hab ich vergessen?

Viele Grüße
Lutz
 

Lesen sie die antworten

#1 Tobias Broer
21/01/2010 - 21:22 | Warnen spam
Hallo Lutz,

schau mal hier, vielleicht hilft dir das:
http://support.microsoft.com/kb/940726/en-us

Viele Grüße
Tobias

"Lutz Rahe" wrote:

Ich hab z.zt. ein Problem bei einem Kunden, da steh ich jetzt "voll auf dem
Schlauch"

Einige konnte ich lsen (u.a. 800401F Fehler)

Folgende Umgebung
2x DC 2003, 1x mit einer Root CA
1x Exchange 2007 SP1 auf 2003 (mail1.firma-hamburg.de)
1x Exchange 2007 SP2 auf 2008 (mail2.firma-hamburg.de)

beide Server haben ein self-signed Zertifikat welches ja 1Jahr gltig ist.
Outlook 2007 keine Probleme, OWA kommt mit Zertifikatsfehler

Also dachte ich mir, mache ich ein Zertifkat mit einem Alternatename

Dazu habe ich auf beiden Servern folgendes eingegeben:
New-ExchangeCertificate -GenerateRequest -SubjectName "cÞ, o=mail1,
cn=owa.mail1.firma-hamburg.de" -IncludeAcceptedDomains -DomainName
mail1 -includeAutodiscover -privatekeyexportable $true -Path c:\cert.req

Sowohl auf Mail1 als auf Mail2. Beide Anforderungen auf der CA eingereicht,
und downgeloadet.
Mit import-ExchnageCertificate importiert und Enable-ExchangeCertificate die
entsprechenden Services eingebunden

Inn den Zertifikaten, die jetzt mail1 (bzw 2).firma-hamburg.de lauten stehen
als zustzliche namen drinnen:
mail1
firma-hamburg.de
firma.de
autodiscover.firma-hamburg.de
autodiscover.firma.de

Die Root CA verteile ich per GPO

Unter OWA gibts jetzt keinen Fehler mehr
Dafr aber im Outlook (2007) beim Start. 2x eine Warnung dass der Name nicht
dem Zertifikat berienstimmt.
Schaue ich mir das Zertifikat an, stimmt aber sowohl der Name als auch die
Zertifikatskette kann aufgelst werden.

Wo liegt da mein Fehler? Was hab ich vergessen?

Viele Gre
Lutz

Ähnliche fragen