Pan Newsreader 0.1.3.6 bricht bei ./configure ab

16/04/2012 - 21:08 von Bernd Rakel | Report spam
Hallo,

wollte mir gerade die neue Beta vom »Pan Newsreader 0.1.3.6« kompilieren
und bekomme zum ersten Mal einen Fehler, den ich nicht beseitigen kann.

user@nb:~/Downloads/pan-0.136$ ./configure --with-gtkspell
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking how to create a ustar tar archive... gnutar
checking whether to disable maintainer-specific portions of Makefiles...
yes
checking for g++... g++
checking whether the C++ compiler works... no
configure: error: in `/home/ben/Downloads/pan-0.136':
configure: error: C++ compiler cannot create executables
See `config.log' for more details
user@nb:~/Downloads/pan-0.136$

Gestartet wurde das Ganze auf LTS Ubuntu 10.04 mit allen aktuellen
Updates, Gnome 2.30.2, bisher konnte ich alle vorherigen neuen Versionen
immer sauber kompilieren und installieren.

Laut <http://wiki.ubuntuusers.de/Programm...lieren> weist es darauf
hin »... dass kein passender Compiler gefunden werden konnte. Er bedeutet
also, dass das Paket build-essential nicht oder nicht korrekt installiert
wurde.«
Eine Neuinstallation des Genannten mit allen installierten Komponenten
brachte keine Besserung, der Fehler bleibt weiterhin bestehen und ich kann
es nicht installieren.

Das in der Fehlermeldung genannte »config.log« hilft mir auch nicht
weiter, böhmische Dörfer für mich.

Hat noch jemand eine Idee,wie ich den Pan nun doch noch installieren kann?
In der Paketverwaltung findet sich nur die alte Version 0.135, mit der ich
gerade schreibe. Direkte binarys für Ubuntu habe ich noch nie gefunden,
mit den letzten vier Versionen klappte alles einfach und funktionierte,
dieser Fehler ist hier neu.
Thx for help.

Der Computer ist die logische Weiterentwicklung des Menschen:
Intelligenz ohne Moral.
(John Osborne)
Grüße aus dem Löwenhaus http://loewenhaus.net
 

Lesen sie die antworten

#1 Uwe Premer
26/04/2012 - 23:46 | Warnen spam
Am Mon, 16 Apr 2012 19:08:52 +0000 schrieb Bernd Rakel:

Hallo,



Hallo Bernd,

wollte mir gerade die neue Beta vom »Pan Newsreader 0.1.3.6«
kompilieren
und bekomme zum ersten Mal einen Fehler, den ich nicht beseitigen kann.

:~/Downloads/pan-0.136$ ./configure --with-gtkspell
configure: error: C++ compiler cannot create executables



Wenn's beim configure schon scheitert, liegt's mit Sicherheit an
fehlenden devs.

Folgende Bibliotheken müssen zwingend im System vorhanden sein:
glib2-devel >= 2.17.6 -> sudo apt-get install libpackagekit-glib2-dev
gmime-devel >= -> sudo apt-get install libgmime-2.4-dev
gtk2-devel >= 2.16.0
gtkspell-devel >= 2.0.7 -> sudo apt-get install libgtkspell-dev

See `config.log' for more details



Du machst einfach nur mal ein "less config.log" und schaust dir damit den
Inhalt dieser Logdatei an, insbesondere die Fehler sind interessant.

Ich hab dann selber mal probiert, diesen Pan zu kompilieren und erhielt
trotz installierten devs diese Errors beim make, was auch bereits in der
Pan-Users-Mailingliste bekannt ist:

Making all in gui
make[3]: Betrete Verzeichnis '/home/.../Downloads/Newsreader/Pan/
pan-0.136/pan/gui'
CXX pan.o
pan.cc:636: error: ISO C++ forbids declaration of ‘GDBusNodeInfo’ with no
type
pan.cc:636: error: expected ‘;’ before ‘*’ token
pan.cc:637: error: ‘GDBusInterfaceVTable’ does not name a type
pan.cc: In constructor ‘<unnamed>::Pan::Pan(pan::Data&, pan::Queue&,
pan::ArticleCache&, pan::EncodeCache&, pan::Prefs&, pan::GroupPrefs&)’:
pan.cc:640: error: class ‘<unnamed>::Pan’ does not have any field named
‘busnodeinfo’
pan.cc: At global scope:
pan.cc:647: error: variable or field ‘nzb_method_call’ declared void
pan.cc:647: error: ‘GDBusConnection’ was not declared in this scope
pan.cc:647: error: ‘connection’ was not declared in this scope
pan.cc:648: error: expected primary-expression before ‘const’
pan.cc:649: error: expected primary-expression before ‘const’
pan.cc:650: error: expected primary-expression before ‘const’
pan.cc:651: error: expected primary-expression before ‘const’
pan.cc:652: error: expected primary-expression before ‘*’ token
pan.cc:652: error: ‘parameters’ was not declared in this scope
pan.cc:653: error: ‘GDBusMethodInvocation’ was not declared in this scope
pan.cc:653: error: ‘invocation’ was not declared in this scope
pan.cc:654: error: expected primary-expression before ‘user_data’
pan.cc:1041: error: expected ‘}’ at end of input
make[3]: *** [pan.o] Fehler 1
make[3]: Verlasse Verzeichnis '/home/.../Downloads/Newsreader/Pan/
pan-0.136/pan/gui'
make[2]: *** [all-recursive] Fehler 1
make[2]: Verlasse Verzeichnis '/home/.../Downloads/Newsreader/Pan/
pan-0.136/pan'
make[1]: *** [all-recursive] Fehler 1
make[1]: Verlasse Verzeichnis '/home/.../Downloads/Newsreader/Pan/
pan-0.136'
make: *** [all] Fehler 2

Wenn der Fehler so auftaucht, soll man configure ohne dbus-Option
ausführen:
./configure --without-dbus

Damit ist dann auch bei mir make durchgelaufen mit dem Ergebnis, dass ich
bereits mit Pan 0.136 hier poste.

Einziger Kritikpunkt von mir: die Version ist in englisch, macht aber nix.

hth, Uwe

Ähnliche fragen