Parameter in benutzerdefinierter Funktion (VBA)

30/06/2008 - 10:25 von Jens Winkler | Report spam
Hallo NG,

eine in VBA geschriebene Funktion (SSumme) soll àhnlich der Funktion
"SUMME" funktionieren, d.h. ich möchte entweder ein zusammenhàngendes
Range übergeben, z.B. SSumme(A1:A10), aber auch unzusammenhàngende
Zellen übergeben, z.B. SSumme(A1:A5;A8;A10).
Das mit dem Range klappt wunderbar, da ich das Argument derart
entgegennehme:

Function Ssumme(ByVal Target As Range)

Bei unzusammenhàngenden Zellen bekomme ich dabei jedoch einen Fehler
angezeigt. Wie kann man solche Parameter nun übergeben bzw. wie wird
soetwas für die Funktion "SUMME" gelöst? Ich konnte dafür leider keine
Lösung finden.

Vielen Dank im Voraus,
Jens
 

Lesen sie die antworten

#1 Hajo_Zi
30/06/2008 - 10:39 | Warnen spam
Hallo Jens,

warum nicht die Funktion von Excl?
=SUMME(B13:B21;BI13:BI21)

Gruß Hajo
MVP für Microsoft Excel
Betriebssystem Vista Ultimate und Excel Version2007
http://Hajo-Excel.de/


"Jens Winkler" wrote:

Hallo NG,

eine in VBA geschriebene Funktion (SSumme) soll àhnlich der Funktion
"SUMME" funktionieren, d.h. ich möchte entweder ein zusammenhàngendes
Range übergeben, z.B. SSumme(A1:A10), aber auch unzusammenhàngende
Zellen übergeben, z.B. SSumme(A1:A5;A8;A10).
Das mit dem Range klappt wunderbar, da ich das Argument derart
entgegennehme:

Function Ssumme(ByVal Target As Range)

Bei unzusammenhàngenden Zellen bekomme ich dabei jedoch einen Fehler
angezeigt. Wie kann man solche Parameter nun übergeben bzw. wie wird
soetwas für die Funktion "SUMME" gelöst? Ich konnte dafür leider keine
Lösung finden.

Vielen Dank im Voraus,
Jens

Ähnliche fragen