Parent Eigenschaften nicht aufrufbar

16/04/2009 - 09:46 von Georg | Report spam
Ich habe eine DB mit mehreren Berichten. In diesen verwende ich einen
Berichtskopf, den ich als subReport gestaltet habe. Nun habe ich in diesem
Header neben dem Logo und weiteren allgemeinen Informationen jeweils den
Berichtstitel als Parent Eigenschaft drin. Dazu gibt es im Hauptbericht
jeweils eine Funktion BerichtsTitel wie folgt:

Public Function BerichtsTitel() As String
BerichtsTitel = 'Name dieses Berichts'
End Function

Im subReport habe ich dann eine Textbox mit DataSource
'=Parent.BerichtsTitel'.

All dies funktionierte wunderbar, solange ich Access 2003 verwendete. Nun
habe ich vor kurzem auf Access 2007 gewechselt, und wàhrend alles andere noch
bestens funktioniert, erhalte ich jeweils nur '#Name' dargestellt, wo
eigentlich der BerichtsTitel sein sollte.

Kann mir da jemand weiter helfen?

Georg
 

Lesen sie die antworten

#1 Henry Habermacher
16/04/2009 - 10:46 | Warnen spam
Hallo Georg

Versuch' mal folgendes: Beim Formattieren Ereignis des Bereiches des UBEs,
in dem die Textbox drinsteht schreibe folgendes rein:

Me!DeineTextBox = Me.Parent.BerichtsTitel()

Die DataSource dann aus der Textbox entfernen. Falls das auch nicht
funktioniert, dann solltest Du hier wenigstens eine Meldung erhalten, wieso
nicht.

Gruss
Henry


Georg wrote:
Ich habe eine DB mit mehreren Berichten. In diesen verwende ich einen
Berichtskopf, den ich als subReport gestaltet habe. Nun habe ich in diesem
Header neben dem Logo und weiteren allgemeinen Informationen jeweils den
Berichtstitel als Parent Eigenschaft drin. Dazu gibt es im Hauptbericht
jeweils eine Funktion BerichtsTitel wie folgt:

Public Function BerichtsTitel() As String
BerichtsTitel = 'Name dieses Berichts'
End Function

Im subReport habe ich dann eine Textbox mit DataSource
'=Parent.BerichtsTitel'.

All dies funktionierte wunderbar, solange ich Access 2003 verwendete. Nun
habe ich vor kurzem auf Access 2007 gewechselt, und wàhrend alles andere
noch bestens funktioniert, erhalte ich jeweils nur '#Name' dargestellt, wo
eigentlich der BerichtsTitel sein sollte.

Kann mir da jemand weiter helfen?

Georg



Los geht's: SEK3 Anmeldung bei www.donkarl.com/?sek
Microsoft MVP Office Access
Keine E-Mails auf Postings in NGs. Danke.
Access FAQ www.donkarl.com

Ähnliche fragen