Forums Neueste Beiträge
 

Partitionstabelle halbwegs zerstoert

21/12/2007 - 22:52 von Andreas Kohlbach | Report spam
Nachdem ich etwa drei Wochen Uptime hatte, muss ich ungeschickt gegen
den Powerknopf gekommen sein. Als ich mich dem Computer wieder widmete,
war er aus. Normal sollte er sauber herunterfahren, das konnte ich aber
aus den Logs nicht heraus lesen, so dass ich von einem harten Off
ausgehe, warum auch immer.

Nach dem Neustart fiel mir auf, dass Programme zwar starteten, aber
nicht wirklich etwas taten (z.B. Firefox auf den Schirm zu kommen),
begleitet von dauernder Festplattenaktivitaet.

Als ich /proc/meminfo untersuchte, stellte ich fest, dass kein Swap
gemountet war. Manuelles Mounten gab etwas mit ungueltiger Swap
Signatur.

Als ich die Partitionstabelle aufrief, das nackte Grausen. Die Linux
Partitionen (reiserfs und ext2) hatten die ID "93 Amoeba", die Swap
hatte "unknown" (die ID habe ich gerade vergesen).

Nachdem ich die, gebootet von Live-CD, neu schrieb, also die IDs
anpasste und neu bootete, schrieb er sie wieder um, oder ich hatte sie
nicht wirklich gespeichert. Beim zweiten Versuch behielt er meine
Aenderungen.

Die Swap wollte er immer noch nicht mounten, also habe ich sie
formatiert. Dann klappte wieder alles.

So weit so gut. Wie kann es aber passieren, dass, selbst bei einem Crash,
die Partitionstabelle offenbar umgeschrieben wird? Da sollte es doch
niemals einen Schreibzugriff geben waehrend des Betriebs?
Andreas
Those who send me spam agree that I visit their web pages and also harvest
addresses. And that I will post them to the usenet to make them unusable. And
that I may flood their web forms with junk. Thank you for your cooperation.
 

Lesen sie die antworten

#1 Arno Lutz
21/12/2007 - 23:27 | Warnen spam
Hallo Andreas Kohlbach,

AK> So weit so gut. Wie kann es aber passieren, dass, selbst bei einem Crash,
AK> die Partitionstabelle offenbar umgeschrieben wird? Da sollte es doch
AK> niemals einen Schreibzugriff geben waehrend des Betriebs?
Wenn ich ab und zu mal wieder in Windows bin und dieses danach nicht sauber
heruntergefahren wird, dann meckert mein 10.3 auch nicht gefundene Partitionen an.
Alle Platten auf den NTFS-Partitionen drauf sind, kann ich danach im 10.3 nicht
ansprechen.
Ich muss nochmals Windows hochfahren und Reboot machen um wieder auf alle zugreifen
zu können.
Dieses Spiel macht Suse erst seit 10.3. Bei noch installiertem 10.1 habe ich keine
Probleme.
Meine Vermutung: ntfs-3g Treiber

Abhilfe habe ich leider keine

Gruß
Arno Lutz

Linux is like a wigwam: no windows, no gates and an apache inside

Ähnliche fragen