passende Zeilen aufsummieren und zählen

03/11/2008 - 13:40 von Jens Mander | Report spam
Hallo,

es ist sicher eine FAQ, aber mangels geeigneter Suchbegriffe habe ich leider
trotzdem nichts gefunden.

Ich habe eine erste Tabelle ("Akten") mit Spalten G, H

Datum Stunden
21.01.2008 2
14.02.2008 6
25.01.2008 2,5
04.03.2008 7
20.03.2008 11
15.02.2008 2,5
20.02.2008 5
03.03.2008 2,5
...

In einer zweiten Tabelle habe ich zwei Spalten

Monat Stunden
1.1.2008
1.2.2008
...

Die erste Spalte habe ich so formatiert, dass Jan 08, Feb 08 etc. angezeigt
wird. In der zweiten Spalte sollen die Stunden aller zu diesem Monat
gehörigen Zeilen der ersten Tabelle summiert werden. Das habe ich mir so
zusammengefummelt:

{=SUMME(WENN((Akten!$G$2:$G$197>DATUM(JAHR(A2);MONAT(A2);1)-1)*(Akten!$G$2:$G$197<DATUM(JAHR(A2);MONAT(A2)+1;1));Akten!$H$2:$H$197;0))}

Reichlich umstàndlich, funktioniert aber.

Frage 1: Geht das nicht einfacher?

Nun soll in einer dritten Spalte die Zahl der aufsummierten Werte (d.h.
Zeilen der ersten Tabelle) ausgegeben werden. Das bekomme ich aber nicht
hin.

Frage 2: Wie kann ich das erreichen?

Vielen Dank für Hilfen und Anregungen!

Jens
 

Lesen sie die antworten

#1 Claus Busch
03/11/2008 - 14:13 | Warnen spam
Hallo Jens,

Am Mon, 3 Nov 2008 13:40:51 +0100 schrieb Jens Mander:

Ich habe eine erste Tabelle ("Akten") mit Spalten G, H

Datum Stunden
21.01.2008 2
...

In einer zweiten Tabelle habe ich zwei Spalten

Monat Stunden
1.1.2008
1.2.2008
...



um es zu vereinheitlichen:
Für die Summe:
=SUMMENPRODUKT((MONAT(Akten!$G$2:$G$200)=MONAT($A2))*(JAHR(Akten!$G$2:$G$200)=JAHR($A2))*(Akten!$H$2:$H$200))
und runterziehen.
Für die Anzahl:
=SUMMENPRODUKT((MONAT(Akten!$G$2:$G$200)=MONAT($A2))*(JAHR(Akten!$G$2:$G$200)=JAHR($A2))*(Akten!$H$2:$H$200<>""))
und runterziehen.

Noch wesentlich einfacher geht es mit einer Pivot-Tabelle. Erstelle aus
den Spalten G und H der Tabelle("Akten") eine Pivot-Tabelle. Ziehe das
Datum in das Zeilenfeld *und* in das Datenfeld, ziehe Stunden in das
Datenfeld. Klicke rechts auf ein Datum und gehe auf Gruppierung und
gruppiere dort nach Monat und Jahr.


Mit freundlichen Grüssen
Claus Busch
Win XP Prof SP3 / Vista Ultimate
Office 2003 SP3 / 2007 Ultimate SP1

Ähnliche fragen