PC Speaker

31/08/2010 - 00:38 von Stefan+Usenet | Report spam
Die Soundkarte auf meinem Motherboard hat in den letzten 3 Monaten
deutliche Stoergeraeusche entwickelt, weshalb ich sie nun durch eine
(auf dem CM8738 basierende) Ultron Octosound 7.1 ersetzt habe.
System ist Debian/Lenny mit Alsa.

Die neue Karte hat auch sofort in der erwarteten Qualitaet
funktioniert - mit genau einer Ausnahme, naemlich der Wiedergabe des
System-Beeps, der fuer mich leider ziemlich wichtig ist.

Der Alsa-Mixer zeigt mir voellig andere Controls an, als zuvor (hat
sich also an die Karte angepasst), aber immer noch einen "PC
Speaker", der auch aktiviert ist:

| sfroehli@sokrates:~$ amixer
| [...]
| Simple mixer control 'PC Speaker',0
| Capabilities: pvolume pvolume-joined pswitch pswitch-joined
| Playback channels: Mono
| Limits: Playback 0 - 3
| Mono: Playback 3 [100%] [on]

Alleine, weder ^G noch beep(1) koennen dem Ding irgendein Geraeusch
entlocken. Abgesehen von der Karte (und daher dem verwendeten
Treiber) hat sich am System nichts geaendert - soweit ich das auf
die Schnelle herausgefunden habe, sind aber beide nicht fuer den
Pieper verantwortlich, sondern das Modul pcspkr, welches nach wie
vor im Speicher herumduempelt.

Hat eventuell jemand eine Idee, wo ich zum Schrauben anfangen
sollte?

Servus,
Stefan

http://kontaktinser.at/ - die kostenlose Kontaktboerse fuer Oesterreich
Offizieller Erstbesucher(TM) von mmeike

Zàrtliche Gefahren braucht die Freiheit: Stefan!
(Sloganizer)
 

Lesen sie die antworten

#1 Andreas Kohlbach
31/08/2010 - 02:52 | Warnen spam
Stefan Froehlich wrote on 30. August 2010:

Die Soundkarte auf meinem Motherboard hat in den letzten 3 Monaten
deutliche Stoergeraeusche entwickelt, weshalb ich sie nun durch eine
(auf dem CM8738 basierende) Ultron Octosound 7.1 ersetzt habe.
System ist Debian/Lenny mit Alsa.

Die neue Karte hat auch sofort in der erwarteten Qualitaet
funktioniert - mit genau einer Ausnahme, naemlich der Wiedergabe des
System-Beeps, der fuer mich leider ziemlich wichtig ist.

Der Alsa-Mixer zeigt mir voellig andere Controls an, als zuvor (hat
sich also an die Karte angepasst), aber immer noch einen "PC
Speaker", der auch aktiviert ist:

| :~$ amixer
| [...]
| Simple mixer control 'PC Speaker',0
| Capabilities: pvolume pvolume-joined pswitch pswitch-joined
| Playback channels: Mono
| Limits: Playback 0 - 3
| Mono: Playback 3 [100%] [on]

Alleine, weder ^G noch beep(1) koennen dem Ding irgendein Geraeusch
entlocken. Abgesehen von der Karte (und daher dem verwendeten
Treiber) hat sich am System nichts geaendert - soweit ich das auf
die Schnelle herausgefunden habe, sind aber beide nicht fuer den
Pieper verantwortlich, sondern das Modul pcspkr, welches nach wie
vor im Speicher herumduempelt.

Hat eventuell jemand eine Idee, wo ich zum Schrauben anfangen
sollte?



Mir fallen zwei Dinge ein.

In alsamixer schauen, ob es das etwas wie "Beep" gibt.

Mal "modprobe pcsprk" als root versuchen.
Andreas
Linux: The choice of a GNU generation.

Ähnliche fragen