Pegel-Info gefragt

31/08/2009 - 09:19 von Gregor Szaktilla | Report spam
Hallo zusammen!

Ich habe eine Anleitung zum Selbstbau einer Kabel-Fernbedienung für den
heimischen PC: Ein paar wenige Teile und ein bisschen Software genügen,
um sowas mit der seriellen Schnnittstelle zu realisieren.

Die in der Anleitung für Rückmeldungen verwendeten LEDs werden mit einem
Widerstand von 2,2 kOhm in Reihe geschaltet (und dann z. B. zw. GND und
RTS geklemmt), was mir seltsam vorkommt, denn m.W.n. wird dort (ich
meine jetzt eine COM-Schnittstelle eines Standard-PCs) mit 5-Volt-Pegeln
gearbeitet. Demnach wàren Widerstànde mit 220 Ohm angesagt.

Meine Vermutung ist, dass sich der Autor der Bauanleitung einfach nur
vertippt hat. Allerdings ist die Anleitung schon reichlich alt und es
wàre schon mehr als genug Zeit für Korrekturen gewesen. Die bisher im
Netz gefundenen Informationen enthalten nur sehr allgemeine
Beschreibungen serieller Schnittstellen und legen sich bezüglich der
verwendeten Pegel nicht fest.

Bevor ich eines meiner Lieblingsspielzeuge schrotte, frage ich also
lieber mal nach: Welche Pegel sind an den seriellen Schnittstellen eines
Standard-PCs üblich?

Es wàre nett, wenn mich jemand mit der passenden Information versorgen
und/oder mich auf eine zuverlàssige Quelle hinweisen könnte.

Falls diese Frage eine FAQ ist, wàre ich für einen Hinweis dankbar, wo
ich diese finden kann.

Gruß und Dank vorweg

Gregor
 

Lesen sie die antworten

#1 Wolfgang Ottenweller
31/08/2009 - 11:05 | Warnen spam
Hallo,

Gregor Szaktilla schrieb:
Die in der Anleitung für Rückmeldungen verwendeten LEDs werden mit einem
Widerstand von 2,2 kOhm in Reihe geschaltet (und dann z. B. zw. GND und
RTS geklemmt), was mir seltsam vorkommt, denn m.W.n. wird dort (ich
meine jetzt eine COM-Schnittstelle eines Standard-PCs) mit 5-Volt-Pegeln
gearbeitet. Demnach wàren Widerstànde mit 220 Ohm angesagt.



http://de.wikipedia.org/wiki/RS232

Bei den uralten PCs wurden +/- 12V ausgegeben, heute üblicherweise nur
noch +/- 5V.

Die Ausgànge sind Signalleitungen, keine Leistungsausgànge, Deine LEDs
müssen mit 1-2mA auskommen weil die Ausgànge nicht mehr hergeben,
deshalb sind die 2.2kOhm korrekt.

Gruß, Wolfgang

Ähnliche fragen