per XDMCP auf KDE zugreifen ... warum geht's nicht immer?

30/07/2010 - 17:11 von Michael Tietsch | Report spam
Hallo Gemeinde,
folgendes: Ich habe 3 x openSUSE 11.3 laufen und möchte auf alle PC per
XDMCP (per Xming) zugreifen.
Alle SUSE-Rechner wurden (gefühlt) gleich installiert. Der Zugriff auf 1
klappt einwandfrei, auf die beiden anderen jedoch nicht. Wo es nicht klappt,
wird der Request auf Port 177 gleich mit "ICMP Port unreachable"
abgeschmettert. D.h. die Firewall ist offen, aber der Serverprocess tut wohl
nichts.
Nun aber der Grund, hier aufzuschlagen: Ich habe zwischen dem geht- und
einem der geht-nicht-PC verglichen und finde keine Ursache. Im Detail:
Nmap bringt nichts Überraschendes:
TCP 6000.6005 auf beiden zu, UDP 177 beim "geht-PC" offen, beim
geht-nicht-PC zu.
Konfig-Dateien:
kdmrc, Xaccess, xdm-config, Xservers ... alle gleich (abgesehen von den zu
erwartenenden kleinen Deltas, wie Zufallszahl, Hostname ...)
Ein Prozesslistenvergleich (ps -AF) ergibt als Unterschied nur, dass der
geht-PC noch eine Zeile "w1_bus_master" aufweist, die im geht-nicht-PC
fehlt. Wenn ich das aber recht verstehe, geht es hier um HW-Resourcen
(Temperaturfühler o.Ä.), richtig?

Wo könnte denn noch ein Unterschied liegen? Gibt es ein Log-File, in dem man
den Hochlauf von XDMCP sehen kann.

Gruß
Michael
 

Lesen sie die antworten

#1 Michael Tietsch
30/07/2010 - 18:39 | Warnen spam
Hi,
Update:
Ich habe einen Unterschied gefunden: in
/var/adm/kdm/kdmrc.sysconfig gibt es einen Abschnitt:
[Xdmcp]
Enable=false

Im "geht-PC" steht das auf "true". Editieren ist leider sinnlos, da es sich
nach jedem Neustart wieder auf "false" veràndert.

Wer weiß mehr dazu?

Danke & Gruß
Michael

"Michael Tietsch" schrieb im Newsbeitrag
news:
Hallo Gemeinde,
folgendes: Ich habe 3 x openSUSE 11.3 laufen und möchte auf alle PC per
XDMCP (per Xming) zugreifen.
Alle SUSE-Rechner wurden (gefühlt) gleich installiert. Der Zugriff auf 1
klappt einwandfrei, auf die beiden anderen jedoch nicht. Wo es nicht
klappt, wird der Request auf Port 177 gleich mit "ICMP Port unreachable"
abgeschmettert. D.h. die Firewall ist offen, aber der Serverprocess tut
wohl nichts.
Nun aber der Grund, hier aufzuschlagen: Ich habe zwischen dem geht- und
einem der geht-nicht-PC verglichen und finde keine Ursache. Im Detail:
Nmap bringt nichts Überraschendes:
TCP 6000.6005 auf beiden zu, UDP 177 beim "geht-PC" offen, beim
geht-nicht-PC zu.
Konfig-Dateien:
kdmrc, Xaccess, xdm-config, Xservers ... alle gleich (abgesehen von den zu
erwartenenden kleinen Deltas, wie Zufallszahl, Hostname ...)
Ein Prozesslistenvergleich (ps -AF) ergibt als Unterschied nur, dass der
geht-PC noch eine Zeile "w1_bus_master" aufweist, die im geht-nicht-PC
fehlt. Wenn ich das aber recht verstehe, geht es hier um HW-Resourcen
(Temperaturfühler o.Ä.), richtig?

Wo könnte denn noch ein Unterschied liegen? Gibt es ein Log-File, in dem
man den Hochlauf von XDMCP sehen kann.

Gruß
Michael

Ähnliche fragen