Performance im Netzwerk

20/06/2008 - 10:09 von S.Remmers | Report spam
Hallo NG,

ich habe eine Planungs-Datenbank entwickelt, die seit Neuesten, beim
Aufrufen von Formularen sehr lange Antwortzeiten hat.

Grundlage der Datenbank ist die Tabellle "tblPlanung". Die habe ich im
Laufe der Zeit um einige Felder erweitern müssen.

Ich habe ein wenig geforscht und festgestellt, dass die Antwortzeiten
besser sind, wenn ich eine alte Tabelle "tblPlanung" einspiele.

Kann ich mir aber nicht erklàren. Hier das Delta zwischen der alten
und neuen Tabelle "tblPlanung"

Anzahl der Felder alt: 40
Anzahl der Feler neu: 119

Anzahl der Datensàtze alt: 29.319
Anzahl der Datensàtze neu: 34.732

Wenn ich mit der "neuen" Tabelle arbeite, liegen die Antwortzeiten im
Minutenbereich, bei der "alten" im Sekundenbereich.

Ich Arbeite mit Windows XP und Access 2003 (11.8166.8172) SP3

Habt Ihr eine Idee woran das liegen kann und wie ich das Problem
behebe?

Gruß
Süntke
 

Lesen sie die antworten

#1 Karl Donaubauer
20/06/2008 - 10:16 | Warnen spam
S.Remmers wrote:

ich habe eine Planungs-Datenbank entwickelt, die seit Neuesten, beim
Aufrufen von Formularen sehr lange Antwortzeiten hat.

Grundlage der Datenbank ist die Tabellle "tblPlanung". Die habe ich im
Laufe der Zeit um einige Felder erweitern müssen.

Ich habe ein wenig geforscht und festgestellt, dass die Antwortzeiten
besser sind, wenn ich eine alte Tabelle "tblPlanung" einspiele.

Kann ich mir aber nicht erklàren. Hier das Delta zwischen der alten
und neuen Tabelle "tblPlanung"

Anzahl der Felder alt: 40
Anzahl der Feler neu: 119

Anzahl der Datensàtze alt: 29.319
Anzahl der Datensàtze neu: 34.732

Wenn ich mit der "neuen" Tabelle arbeite, liegen die Antwortzeiten im
Minutenbereich, bei der "alten" im Sekundenbereich.

Ich Arbeite mit Windows XP und Access 2003 (11.8166.8172) SP3

Habt Ihr eine Idee woran das liegen kann und wie ich das Problem
behebe?



Soll das heißen, dass du mit dem identen neuen Formular nur auf
die alte Tabelle mit demselben Namen wechseln musst, damit
sich die Antwortzeiten normalisieren? Oder ànderst du noch etwas?

Sind im Menü Extras/Optionen/Allgemein
alle Haken im Abschnitt
"Objektnamen-Autokorrektur" entfernt?

HTH
Karl
********* Ich beantworte keine Access-Fragen per Email. *********
Access-FAQ: http://www.donkarl.com
+ Entwickler-Konferenzen für Access und SQL Server

Ähnliche fragen