Performanceprobleme

10/12/2007 - 02:11 von Andreas Lammert | Report spam
Hallo!

Ich habe beim Windows 2003 Server folgendes Problem:
Auf dem Server làuft eine Datenbankanwendung programmiert in VFP 9. Die
Clients sind entweder WindowsXP (7 Clients) oder Vista (2 Clients). Frage
ich nun vom Client aus Daten aus der Datenbank mittels SQL Abfrage aus, so
habe ich folgendes Phànomen:

1. Wenn der Server neu gestartet wurde, làuft die Abfrage sehr schnell (ca.
4 Sekunden, über das Netzwerk werden ca. 17 MB Daten übertragen)

2. Làuft der Server lànger als eine halbe Stunde, so dauert die Abfrage ca.
1 Minute und es werden bis zu 700 MB Daten übertragen

3. Kopiere ich die Datenbank auf einen anderen 2003 Server der schon làngere
Zeit làuft, so habe ich auch das unter "2." beschriebene Verhalten.

4. Kopiere ich die Datenbank auf einen XP Rechner und verwende den als
"Server", so habe ich das unter "1. " beschriebene Verhalten.

An der Abfrage hat sich aber nichts geàndert. Die Datenbank welche abgefragt
wird, hat eine Größe von ca. 30 MB.

An der Programmierung und am Verhalten der Datenbank von VFP 9 kann es nicht
liegen, das wurde bereits umfassend abgeklàrt.

Was macht der 2003 Server denn da??? Warum übermittelt er immer so große
Datenmengen??


Danke für euere Hilfe im Voraus

Andreas Lammert

P.S.: Ich selbst bin Programmierer und keine Profi-Serveradmin. Ich bin aber
der, der die Sache zum Laufen bringen muss!!
 

Lesen sie die antworten

#1 Robert Riebisch
10/12/2007 - 10:55 | Warnen spam
Andreas Lammert wrote:

Was macht der 2003 Server denn da??? Warum übermittelt er immer so große
Datenmengen??



Probiere mal das: http://support.microsoft.com/kb/904946/en-us

P.S.: Ich selbst bin Programmierer und keine Profi-Serveradmin. Ich bin aber
der, der die Sache zum Laufen bringen muss!!



Komisch, auf deiner Website steht was anderes. ;-(

Robert Riebisch
Bitte NUR in der Newsgroup antworten!
Please reply to the Newsgroup ONLY!

Ähnliche fragen