Perverses NAT-Problem mit SIP

19/11/2008 - 16:09 von Christian Baer | Report spam
Hallo liebe Lesenden!

NAT-Threads gibt es hier so einige und im IP-Phone-Forum mehr als genug.
Das habe ich auch schon gesehen. Ich habe auch schon ein ganze Reihe mit
diversen Verlinkungen zu anderen Threads, Anleitungen und HowTos durch.
Wie so hàufig in meinem Leben habe ich hier einen Spezialfall, für den
es keine fertige Lösung gibt und den ich entsprechend behandeln muß.

Hintergrund:
Bei mir steht der Wechsel des Zugangs-ISPs an (von der Telekom zu O2).
Der Grund:
- Kosten: Die Telekom hat mich monatlich rund 70 Euronen gekostet.
- Bandbreite: Bei der Telekom hatte ich eine ADSL mit 3072KBit/s, bei O2
bekomme ich eine ADSL2+ rate adaptive, was bei meiner Dàmpfung noch gut
12MBIt/s ausmachen sollte.

Die MSNs hatte ich vorher schon zu Sipgate portiert. Darunter war auch
eine dreistellige Rufnummer, die ich auf keinen Fall verlieren will.
Deshalb habe ich auch abgewartet, bis die Portierung abgeschlossen war,
bevor ich den neuen Auftrag für den Zugang erteilt habe. Die Folge: Ich
habe derzeit keinen eigenen Internetzugang (zu Hause). Irgendwie bekommt
die Telekom es nicht auf die Kette, den neuen Zugang dann auch zu
schalten. Mein TAL ist noch aufgeschaltet (das Modem sychronisiert mit
der TI-Krücke der Telekom), aber schon zweimal sind Schaltungstermine
verstrichen ohne Ergebnis.

Damit ich zumindest ins Netz kann für Mail, News, eBay und Co. habe ich
mich mit meiner Nachbarin geeinigt, daß ich ihren Zugang mitnutzen darf.
Die Verbindung wird über WLAN hergestellt und steht soweit. Surfen, Mail
und alles funktioniert auch soweit (sogar ICQ), aber SIP eben nicht. Das
war mir eigentlich vollkommen Wumpe, doch wie es scheint, verzögert sich
der Anschluß bei O2 noch etwas mehr, weshalb ich gerne SIP
funktionsfàhig machen würde.

Das Problem:
Wegen der Tatsache, daß ich meinen Internetzugang nicht selber in der
Hand habe und ich gleichzeitig weder mein LAN noch das meiner Nachbarin
irgendwie groß veràndern wollte, steht jetzt folgendes Netz:


Mein LAN (192.168.100.0)
|
|
|
Fritzbox 7270 (192.168.100.250) mit aktueller "Laborware"
|
|
|
Siemens SE505v1 (192.168.100.240 LAN-seitig) mit DD-WRT v23SP2
| (192.168.2.50 WLAN-seitig) als WLAN Client
|
|
Arcor EasyBox A 600 (192.168.2.1) von meiner Nachbarin
| \
| \
| \
| \
Internet LAN meiner Nachbarin (192.168.2.0)

In meinem LAN làuft ein unabhàngiger DHCP-Server, der statische Adressen
an bekannte Rechner vergibt. Die Fritz und der SE505 beziehen keine
Adresse sondern haben ihre direkt vorgegeben (beim SE505 trifft das für
beide Adressen zu). Standardgateway ist die Fritz. Wenn ich irgendwann
mal wieder einen eigenen Zugang habe, muß ich nur in der Fritz etwas
àndern. Die Fritz ist derzeit konfiguriert als IP-Client und hat als
Standardgateway den SE505. Der SE505 hat als Standardgateway 192.168.2.1
eingestellt.

Das funtkioniert für viele Sachen (wie oben erwàhnt) auch ganz gut. Ein
mtr sieht richtig cool aus. :-) Sip funktioniert aber nicht so richtig.

Ganz ohne Einstellungen (also ohne Portforwarding und Co.) funktioniert
SIP bei Sipgate teilweise. Die Anmeldung klappt, ausgehende Anrufe
klappen auch hin und wieder. Gleiches gilt für ankommende Anrufe. Wenn
mal eine Verbindung da ist, können sich die Parteien auch unterhalten.
"Einseitige" Gespràche hatte ich bislang noch nicht. Aber, das klappt
halt eben nicht immer.

Ich habe noch ein paar SIP-Rufnummern von der Arbeit, die ich mir mit
nach Hause nehme, wenn ich nicht im Büro bin. Diese Rufnummern sind von
1&1. Da klappt die Anmeldung erst gar nicht.

Dann habe ich versucht, mit Portfarwarding die Sache zu entschàrfen.
Folgendes habe ich gemacht (Portnummern sind die Eingangsports):

6060-606 6078-6097
Arcor Easybox
|
|
5060-6061 7078-7097
Siemens SE505
|
|
5050-5060 7068-7097
Fritzbox 7270

Stun-Server sind eingerichtet.
Interessanterweise hat das zur Folge, daß SIP jetzt gar nicht mehr geht.
Ich kann nicht mehr raustelefonieren und angerufen werden kann ich auch
nicht mehr. Es kommt nur die Meldung "Der gewünschte Gespràchspartner
[...]" Interessant dabei ist, daß ich bei Sipgate grünes Licht bekomme
(angemeldet), wàhrend ich bei 1&1 nur Timeouts kassiere.

Nun die Frage an die Experten: Gibt es einen Brandheißen Tip, wie ich
das zum Laufen bringe? Habe ich (mal wieder) nur etwas übersehen?

Beste Grüße dem schönen Westfalen!
Christian

Ich kam.
Ich ging.
Und ich war da gewesen.
 

Lesen sie die antworten

#1 Andreas Schiller
20/11/2008 - 00:21 | Warnen spam
Hallo Christian,

dein NAT-Problem ist zwar nicht trivial, doch keinesfalls pervers.

Was die Angelegenheit komplexer macht, ist die SIP-Telefonie-Funktion in
der Arcor EasyBox A600 deiner Nachbarin.

Hier hat Markus Betz vor ca. 18 Monaten seine Lösung u.a. mit Änderung
der Portnummern in der "inneren" Fritz!Box:
<http://de.nntp2http.com/comm/intern...6.html>


Vermutlich hast du das schon gefunden:
AVM:
"Die Lösung besteht darin, dass Sie im vorgeschalteten Router folgende
statische Portweiterleitungen konfigurieren:

- von beliebigem noch nicht verwendeten UDP-Port ab 1024 (z.B. 6060) auf
Port 5060 der IP-Adresse des nachgeschalteten FRITZ!Box Fon-Geràtes
- von beliebigem noch nicht verwendeten UDP-Ports ab 1024 (z.B.
6078-6097) auf 7078-7097 der IP-Adresse des nachgeschalteten FRITZ!Box
Fon-Geràtes"
http://www.ip-phone-forum.de/showthread.php?t7428


Dann habe ich versucht, mit Portfarwarding die Sache zu entschàrfen.
Folgendes habe ich gemacht (Portnummern sind die Eingangsports):

6060-606 6078-6097
Arcor Easybox
|
|
5060-6061 7078-7097
Siemens SE505
|
|
5050-5060 7068-7097
Fritzbox 7270



Ich verstehe Dein Portweiterleitungs-Schema nicht.

Stun-Server sind eingerichtet.



Das ist nichts neues, die werden von Millionen Nutzern seit Jahren
verwendet.
:-)
Im Erst, die Verwendung von STUN sollte auf deiner Fritz!Box 7270
aktiviert sein.


HTH
Andreas Schiller

Ähnliche fragen