PHP 5.2.4 unter Solaris 2.7?

15/10/2007 - 22:38 von Roland Haeder | Report spam
Moin,

in der Newsgroup de.alt.folklore.computer hat man mir empfohlen hier her zu
kommen (ist wohl wegen der Thematik am passensten). Also stelle ich hier
einfach die Frage noch einmal:

Auf http://www.sunfreeware.com/ gibt es PHP5-Pakete zum Download, die auch
wunderbar klappen, bis auf eines halt:

Keinen Socket-Support. Ich moechte hier keinen "Glaubenskrieg" anfangen, ob
PHP5 fuer Server-Programmierung geeignet ist oder nicht, aber ich vermisse
halt genau diese Funktionen fuer mein neues Projekt (Ship-Simu wird es
heissen).

Meine Frage nun:

Hat wer es geschafft, PHP5 mit moeglichst allen Extensions unter Solaris 2.7
mit dem GNU C Compiler zu kompilieren? Ich stosse hier massivst auf
Linker-Probleme. (Ich kann gerne die Fehlermeldungen kopieren).

Ich bin bereits durch den configure-Teil hindurch und auch die Kompilierung
klappte, die letzte Link-Anweisung um php-cgi zu bauen, klappte leider
nicht (irgentwelche Meldungen, wie ich schon sagte, ich kann sie hier gerne
reinposten).

Bis auf recode konnte ich alle Extensions konfigurieren (configure mit
aetlich vielen --with-blabla Parametern) und kompilieren, nicht aber das
Binary php-cgi kompilieren.

Danke fuer die Hilfe im Voraus. :)

VG,
Roland
 

Lesen sie die antworten

#1 Daniel Rock
15/10/2007 - 23:39 | Warnen spam
Roland Haeder wrote:
Ich bin bereits durch den configure-Teil hindurch und auch die Kompilierung
klappte, die letzte Link-Anweisung um php-cgi zu bauen, klappte leider
nicht (irgentwelche Meldungen, wie ich schon sagte, ich kann sie hier gerne
reinposten).



Mal ins blaue geraten:

Setze zu den gcc-Flags beim Linken zum "-shared" noch ein "-mimpure-text"
hinzu. Oder schmeiß alle Vorkommen von "-z text" aus libtool hinaus.

Aber: Wer setzt heute noch Solaris 7 ein? Das OS ist fast 10 Jahre alt,
seit bereits 4 Jahren EOL, seit 2 Jahren gibt es keine neuen Patches und
in einem Jahr ist es komplett EOSL. Da kann ich mir bessere Plattformen
für PHP vorstellen.

Daniel

Ähnliche fragen