PHP reagiert unter IIS anders als unter Apache?

06/11/2008 - 09:30 von Ralph A. Schmid, dk5ras | Report spam
Moin,

ich habe auf einem w2k-server eine Installation aus Apache, php5,
mysql und Wordpress laufen, die einwandfrei funktioniert. Wenn ich nun
auf das selbe www-root auf einem anderen port einen IIS installiere,
ihm über die isapi-dll php beibringe und dann die website aufrufe,
bekomme ich von Wordpress diese Fehlermeldung:

"Ihrer PHP-Installation fehlt die MySQL-Erweiterung, welche für
WordPress notwendig ist"

Was will also php für eine Erweiterung, daß es den IIS an mysql
'ranlàßt?

Diese extensions sind aktiv:

extension=php_mysql.dll
extension=php_mysqli.dll
extension=php_pdo.dll
extension=php_pdo_mysql.dll

Sicher ist es nur irgend eine Kleinigkeit, die ich vergessen habe,
aber ich verstehe wohl noch zu wenig davon, um diese zu entdecken...

Danke für alle Hinweise, wie und wo ich weitersuchen kann!


-ras


Ralph A. Schmid

http://www.dk5ras.de/ http://www.db0fue.de/
http://www.bclog.de/
 

Lesen sie die antworten

#1 Claus Reibenstein
06/11/2008 - 09:41 | Warnen spam
Ralph A. Schmid, dk5ras schrieb:

"Ihrer PHP-Installation fehlt die MySQL-Erweiterung, welche für
WordPress notwendig ist"

Was will also php für eine Erweiterung, daß es den IIS an mysql
'ranlàßt?



Die Fehlermeldung spricht von der "MySQL-Erweiterung, welche für
WordPress notwendig ist". Es scheint also etwas WordPress-spezifisches
zu sein. Hier sollte die WordPress-Doku weiterhelfen.

Gruß. Claus

Ähnliche fragen