php4 und/oder php5 mit Apache2

19/09/2007 - 17:46 von Armin Barth | Report spam
hallo,
ich habe auf einem Ubuntu (6.06) -Server einen Apache2 laufen.
Das installierte php4 und/oder php5 (ich habe beide Versionen unabhàngig von
einander probiert) wird aber von Apache2 nicht aussgewertet, d.h. .php
Programme lassen sich nicht starten und es kommt die Fehlermeldung:

********************************
Internal Server Error

The server encountered an internal error or misconfiguration and was unable
to complete your request.

Please contact the server administrator, webmaster@localhost and inform them
of the time the error occurred, and anything you might have done that may
have caused the error.

More information about this error may be available in the server error log.
Apache/2.0.55 (Ubuntu) mod_perl/2.0.2 Perl/v5.8.7 Server at
freddy.barth-geraete.de Port 80
********************************

Das php4-Modul ist im Verzeichnis /etc/apache4/mods-availabel als Modul und
als Load vorhanden und auch im /etc/apache2/mods-enabled verlinkt.

a2enmod php4 sagt mir, dass das Modul bereits geladen ist.

Den Apache2 habe ich bereits mehrfach neu gestartet.

Was kann ich noch tun um Apache2 mitzuteilen, dass er php verarbeiten soll?

Gruß
Armin
 

Lesen sie die antworten

#1 Carsten Wiedmann
20/09/2007 - 00:54 | Warnen spam
Armin Barth schrieb:

********************************
Internal Server Error

The server encountered an internal error or misconfiguration and was
unable to complete your request.
...
Was kann ich noch tun um Apache2 mitzuteilen, dass er php verarbeiten
soll?



Zuerst sollte man tun, was der Apache dir schon nahelegt:

More information about this error may be available in the server error
log.



Was steht also im error_log?

Gruß
Carsten

Ähnliche fragen