php5 auf Suse10.3

09/04/2008 - 10:06 von Hago Ziegler | Report spam
Hallo,

ich habe mir ein Suse10.3 installiert.
Wenn ich localhost aufrufe, findet es Apache2. Er làuft also.
Wenn ich eine php-Datei aufrufe wird mir nur der Download angeboten.

In /etc/php5/apache2 habe ich eine php.ini gefunden und "Document Root"
und das home-Verzeichnis angegeben.
Das Gleiche in /etc/php5/cli

Das Apache php5-Modul habe ich in /usr/lib/apache2 gefunden

Ich verstehe nicht was falsch làuft.
In der Suse10.2 ging's erstmal ohne spezielle Einstellungen.

Kann mir jemand helfen?

Hago
 

Lesen sie die antworten

#1 Joerg Behrens
09/04/2008 - 10:48 | Warnen spam
Hago Ziegler schrieb:
Hallo,

ich habe mir ein Suse10.3 installiert.
Wenn ich localhost aufrufe, findet es Apache2. Er làuft also.
Wenn ich eine php-Datei aufrufe wird mir nur der Download angeboten.

In /etc/php5/apache2 habe ich eine php.ini gefunden und "Document Root"
und das home-Verzeichnis angegeben.



Wuesste nicht warum und wo man in der php.ini "Document Root" und $HOME
angibt da es von denen ja mehr als eines geben kann.

Das Gleiche in /etc/php5/cli



CLI ist PHP als Komandozeileninterpreter.

Das Apache php5-Modul habe ich in /usr/lib/apache2 gefunden




Stelle sicher das dieses Modul auch geladen wird. Normal stehen die
Ladeanweisungen in einer Bedingung innerhalb der httpd.conf.

<IfDefine FOO>
Load Module bubb
</IfDefine>


<IfModule blubb>
Add Type
</IfModule>


Sollte deine Suse sowas benutzen musst du gucken wie die man das FOO
definiert so das es das Startscript kennt.

Gruss
Joerg


TakeNet GmbH, Geschaeftsfuehrer Wolfgang Meier
97080 Wuerzburg Tel: +49 931 903-2243
Alfred-Nobel-Straße 20 Fax: +49 931 903-3025
HRB Wuerzburg 6940 http://www.takenet.de

Ähnliche fragen