PHP5 unter w2k tut nicht...

13/10/2008 - 13:25 von Ralph A. Schmid, dk5ras | Report spam
Moin,

ich haber hier einen Apache 2.2 unter w2k, dazu php5 und mysql, und
ich mag gerne wordpress installieren. Der server ist auch physikalisch
zugànglich (keine Miet-Kiste), backups sind vorhanden, und das System
hat keinen produktiven Sinn, insofern kann nix passieren :-)

Nach anfànglichen Verwirrungen mit dieser unsàglichen Marotte, mal C:/
und mal C:\ zu erlauben und Fehlermeldungen, daß die extensions nicht
gefunden werden, habe ich die Pfade hinbekommen, daß alles làuft, php
und wordpress haben funktioniert. Nach einem Wochenende Urlaubs und
einem Neustart des Rechners geht nun aber nix mehr :) Im accesslog
bekomme ich das:

84.147.157.189 - - [13/Oct/2008:13:05:50 +0200] "GET
/wordpress/index.php HTTP/1.1" 301 -

Was will mir dieser 301er genau sagen? Wo soll ich ansetzen, um
überhaupt zu finden, was da schiefgeht? Die normalen http-Seiten des
servers werden geliefert, funktioniert alles bestens.

Nach einem erneuten Neustart des gesamten servers sieht das log des
Indianers folgendermaßen aus:

[Mon Oct 13 12:33:12 2008] [warn] pid file C:/Program Files/Apache
Software Foundation/Apache2.2/logs/httpd.pid overwritten -- Unclean
shutdown of previous Apache run?
[Mon Oct 13 12:33:14 2008] [notice] Apache/2.2.9 (Win32) PHP/5.2.6
configured -- resuming normal operations
[Mon Oct 13 12:33:14 2008] [notice] Server built: Jun 13 2008 04:04:59
[Mon Oct 13 12:33:14 2008] [notice] Parent: Created child process 1504
[Mon Oct 13 12:33:14 2008] [notice] Child 1504: Child process is
running
[Mon Oct 13 12:33:14 2008] [notice] Child 1504: Acquired the start
mutex.
[Mon Oct 13 12:33:14 2008] [notice] Child 1504: Starting 64 worker
threads.
[Mon Oct 13 12:33:14 2008] [notice] Child 1504: Starting thread to
listen on port 80.

Sieht für mich relativ normal aus.

Man mag mir verzeihen, wenn ich mich saudoof anstelle, aber das Ganze
ist einfach neu für mich, ich befasse mich damit überhaupt erst seit
ein paar Tagen, und für einen, der bisher nur einen Windows-server mit
diversen IIS-Diensten betreut hat, ist das halt alles etwas seltsam.

Danke für ein wenige Erhellung, uind viele Grüße!


-ras


Ralph A. Schmid

http://www.dk5ras.de/ http://www.db0fue.de/
http://www.bclog.de/
 

Lesen sie die antworten

#1 Carsten Wiedmann
13/10/2008 - 13:49 | Warnen spam
Ralph A. Schmid, dk5ras schrieb:
84.147.157.189 - - [13/Oct/2008:13:05:50 +0200] "GET
/wordpress/index.php HTTP/1.1" 301 -

Was will mir dieser 301er genau sagen?



301 ist ein Redirect [1]. (ausgelöst wohl durch Wordpress)

Wo soll ich ansetzen, um
überhaupt zu finden, was da schiefgeht?



"error.log" z.B.
Mit z.B. "LiveHTTPHeaders" im FF könnte man auch schauen, wohin der Redirect
führt. (bzw. sollte das dein Browser auch dann in der Adressleiste anzeigen)

BTW:
Was geht denn überhaupt schief (und was sagt der Wordpress-Support dazu)?

Gruß
Carsten


[1] http://www.w3.org/Protocols/rfc2616...#sec10.3.2

Ähnliche fragen