pid file missmatch

08/09/2010 - 16:00 von Paul-Wilhelm Hermsen | Report spam
Habe unter OpenSuSE und unter Ubuntu ein Serverprogramm installiet, mit
dem ich meine Telefonanlage AGFEO steuern kann (TKSuite). Beim Start des
Programms wird ein pid file generiert, welches die Prozessnummer enthàlt.
Wàhrend nun unter Ubuntu das pid file ordnungsgemàß generiert wird und
die Prozessnummer auch tatsàchlich da ist, wird unter OpenSuSE zwar
zunàchst ein derartiges file generiert, es ist aber leer, obwohl es
angeblich korrekter Weise 5 Bytes enthalten soll und es verschwindet
nach einigen Sekunden wieder aus dem Verzeichnis.
Logischer Weise làuft der Server unter Ubuntu korrekt und unter OpenSuSE
nicht.
Hat jemand dafür eine Erklàrung und kann Abhilfe schaffen?
 

Lesen sie die antworten

#1 Ansgar Strickerschmidt
08/09/2010 - 17:14 | Warnen spam
Also schrieb Paul-Wilhelm Hermsen:

Habe unter OpenSuSE und unter Ubuntu ein Serverprogramm installiet, mit
dem ich meine Telefonanlage AGFEO steuern kann (TKSuite). Beim Start des
Programms wird ein pid file generiert, welches die Prozessnummer enthàlt.
Wàhrend nun unter Ubuntu das pid file ordnungsgemàß generiert wird und
die Prozessnummer auch tatsàchlich da ist, wird unter OpenSuSE zwar
zunàchst ein derartiges file generiert, es ist aber leer, obwohl es
angeblich korrekter Weise 5 Bytes enthalten soll und es verschwindet
nach einigen Sekunden wieder aus dem Verzeichnis.
Logischer Weise làuft der Server unter Ubuntu korrekt und unter OpenSuSE
nicht.
Hat jemand dafür eine Erklàrung und kann Abhilfe schaffen?



Sowas müsste doch Spuren im Log (/var/log/messages oder dmesg)
hinterlassen...

Ansgar

*** Musik! ***

Ähnliche fragen