Pivot kumulieren ohne "PIVOTDATENZUORDNEN()"

19/06/2009 - 18:10 von Darylando | Report spam
Ich habe ein Tabellenblatt mit folgenden Beispielwerten

Datum Produkt
01.01.09 A
02.01.09 A
03.01.09 A
04.01.09 B
05.01.09 B
06.01.09 C
07.01.09 A

Anschließend wird eine Pivottabelle erstellt, die Zeilen sind das Produkt,
die Anzahl der "Datum" in "% des Ergebnisses" sind die Werte, das sieht dann
so aus:

A 57,14%
B 28,57%
C 14,29%
Gesamtergebnis 100,00%

Ziel ist, auf einfache Arte eine Spalte hinzuzufügen, die die Prozentwerte
der letzten Zeile jeweils aufsummiert, also:

A 57,14% 57,14%
B 28,57% 85,71%
C 14,29% 100,00%
Gesamtergebnis 100,00%

Wenn ich die Spalte neben der Pivottabelle anlege, erhalte ich zB als Formel
in der Zeile von Produkt B [Zelle] + PIVOTDATENZUORDNEN("Anzahl von
Datum",$A$3;"Produkt";"B") wobei diese Formel nicht nach "unten gezogen"
werden kann, was bei vielen Daten blöd ist.

Irgendwelche Ideen?
 

Lesen sie die antworten

#1 Frank Arendt-Theilen
19/06/2009 - 21:53 | Warnen spam
Hallo Darylando,
für XL2003 :
Führe bei aktivem PivotTable einen Rechtsklick auf die Symbolleiste
"PivotTable" aus. Klicke am Ende der Symbolleiste auf den
DropdowPfeil, zeige auf "Schaltflàche hinzufügen oder entfernen",
zeige dann auf "PivotTable" und klicke abschließend auf "GetPivotData
generieren". Diese Schaltflàche wird der Symboleiste hinzugefügt. Ist
diese Schaltflàche aktiv, wird bei einem Klick in den PivotTable im
Formelaufbau die von dir genannte Funktion PIVOTDATENZUORDNEN()
benutzt, ansonsten die normele Zellreferenzierung, also deaktiviere
diese Schaltflàche.

Für XL2007:
Klicke bei aktivem PivotTable in die kontextbezogene Registerkarte
"Optionen", in der Gruppe "PivotTable", auf die Schaltflàche
"Optionen" und deaktiviere den Befehl "GetPivotData generieren".

Unabhàngig von der obigen Beschreibung kannst du neben dem PivotTabel
die Formel =SUMME($B$4:B4) "hàndisch" eintragen und nach unten
kopieren. Die Werte werden kumuliert.


Mit freundlichem Gruß aus der Rattenfàngerstadt Hameln
Frank Arendt-Theilen
(ehem. MVP für Excel)
Website: www.xl-faq.de
Microsoft - Excel, Bedingte Formatierung, ISBN: 978-3-86645-806-2

Ähnliche fragen