Pivotfrage (Berechnetes Element)

06/01/2008 - 18:40 von Heckner | Report spam
Hallo

ich habe folgende Tabelle

Name Wert Prozent
A 200 10%
B 100 15%
A 400 30%
B 50 20%

usw.

nun möchte ich mit Hilfe einer Pivottabelle eine Auswertung die mir
folgendes liefert:

Summiere alle Werte zu einem Namen und gewichte sie mit ihrem
Prozentwert.

Beispiel:

Für A
200*10% + 400*30% = 140

Ich habe das mit Berechnetem Element und Berechnetem Feld.

Aber das haut nicht hin

Mir bleibt nur die Lösung eine weitere (versteckte) Spalte
"Gewichtung" einzuführen und mir ihr die Summe in der Pivottabelle zu
bilden , oder gibt es einen geschickteren Weg über obige genannte
Elemente

Grüße
Hannes
 

Lesen sie die antworten

#1 Alexander Wolff
06/01/2008 - 19:40 | Warnen spam
Das Problem liegt woanders.

Wenn Pivot aggregiert (und das soll es ja mit A und B), geht dort die
Einzelinformation verloren, bevor Du eine Berechnung durchführst. Auch die
Ergebnisse zu A und B selbst wàren ja nicht in Deinem Sinne:

Summe? 600 und 40% - ist Quatsch
Mittelwert? 300 und 20% - ist genauso Quatsch

D.h., die aggregierte Tabelle ergàbe nur Quatsch. Du mussst also tatsàchlich
in den Quelldaten eine Summenspalte verwenden oder in der Pivot-Tabelle
dafür sorgen, dass nicht aggregiert wird. Aber dann bringt sie Dir nix ggü
den Quelldaten.

Es ginge auch mit
=SUMMENPRODUKT(($A$1:$A$999="A")*$B$1:$B$999*$C$1:$C$999)

Setze diese Formel neben Deine Pivottabelle, die als Zeilenfelder "Name"
hat, und ersetze "A" durch das Zeilenfeld. Wenn das Zeilenfeld in P4 seinen
ersten Eintrag hat, stellst Du also rechts neben die Pivottabelle die
normale Tabellenformel

=SUMMENPRODUKT(($A$1:$A$999=P4)*$B$1:$B$999*$C$1:$C$999)
und kopierst sie runter.

Wert Prozent
A 600 40% 140
B 150 35% 25

Beachte aber, dass die Formel manuell angepasst werden muss, wenn sich was
an der Pivottabelle àndert.
Moin+Gruss Alexander - MVP für MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen